*RESOLVED* HELP - mysterious transfer


#1

I discovered today while making some test calls, that if i dial # from the called extension, the calling extension is put on hold & the called party is given a “transfer” prompt.

For example:

200 calls 201
201 answers and dials #
200 is put on hold & hears MoH
201 hears “transfer” …then there is a pause (waiting for digits?)
201 then hears “i am sorry, that is not a valid extension, please try again”

I cannot seem to find any configuration for this. Is there a way of disabling it, or at least changing the digit.
I need the # to be sent through to the calling party, which is a messaging system.


#2

This is default asterisk behavior - no mystery, there. I believe that you can change this at runtime if you’re running a newer version (1.2 beta, for example) in features.conf.

[featuremap]
;blindxfer => #1                ; Blind transfer
;disconnect => *0               ; Disconnect
;automon => *1                  ; One Touch Record
;atxfer => *2                   ; Attended transfer

#3

Thanks for the info, but that doesn’t seem to help. I am using the stable build 1.09 (in Asterisk@home)

The only entries in my features.conf is:

[general]
parkext => 70				; What ext. to dial to park
parkpos => 71-79			; What extensions to park calls on
context => parkedcalls			; Which context parked calls are in
#parkingtime => 60			; Number of seconds a call can be parked for (default is 45 seconds)

Is there any way of changing or disabling this feature in 1.09 without upgrading?


#4

Not to my knowledge. You could modify the source code (assuming you built from source), but I wouldn’t recommend it.


#5

Well, I take that back. You could do some sneaky things with how your hardphone passes DTMF, and how Asterisk listens for DTMF. For example, you could pass DTMF in audio and tell asterisk to look for it in RTP. You might end up not being able to use Voicemail, Directory, or other PBX functions, however.


#6

Sounds good in theory, can you give me a clue where you set this in asterisk?

I am fairly new to Asterisk, so am still finding my way around.

Thanks


#7

Well, in your sip.conf (assuming that your hardphone is running sip), the setting is dtmfmode. On the handset, you will have to reference its documentation.

For example:

[bt102-2]
type=friend
canreinvite=yes
host=dynamic
mailbox=1234
username=1234
secret=gandalf
dtmfmode=rfc2833

Note that though the example above specifies dtmfmode on a client basis, it can be set globally in the [general] context of sip.conf. Go to http://voip-info.org/tiki-index.php?page=Asterisk+config+sip.conf for more info.


#8

Sorry to interrupt, but I think you’re wrong.

The behaviour you describe is a Dial command feature. In fact it’s the “t” parameter in Dial command. For more details go see : voip-info.org/tiki-index.php … k+cmd+Dial


#9

Francois,

That worked. I can still use the transfer button on the SIP phone to transfer callers, but # is now passed straight through.

Exactly what i needed.

Thanks a lot


#10

I think it depends on your point of view, or on your specific needs. I implied that my makeshift solution was wrong, and I appreciate you stepping up to provide an alternate solution.

I could definitely construct a scenario where this would be a problem, and I believe that is why the newer features module allows for reassignment of the transfer button.