Call transfer issue


I’m using Asterisk on Ubuntu with CAPI on a Fritz! Card and ZAPHFC on an internal HFC card in NT mode as well as a few SIP phones.

The problem is that I cannot transfer a call, neither with my SIP phones, nor with one of the internal ISDN phones that are connected to the card that’s in NT mode. Whenever i press “*” or “#”, the DTMF tone is being sent to the call partner instead of starting any call transfer function.

Probably I have not configured my Asterisk properly, but I don’t know wheren.

This is my features.conf:

; Sample Parking configuration

parkext => 700 ; What extension to dial to park
parkpos => 701-720 ; What extensions to park calls on. These needs
to be
; numeric, as Asterisk starts from the start po
; and increments with one for the next parked c
context => parkedcalls ; Which context parked calls are in
;parkingtime => 45 ; Number of seconds a call can be parked for
; (default is 45 seconds)
;transferdigittimeout => 3 ; Number of seconds to wait between digits when
transferring a call
;courtesytone = beep ; Sound file to play to the parked caller
; when someone dials a parked call
;xfersound = beep ; to indicate an attended transfer is complete
;xferfailsound = beeperr ; to indicate a failed transfer
;adsipark = yes ; if you want ADSI parking announcements
;findslot => next ; Continue to the ‘next’ free parking space.
; Defaults to ‘first’ available
;pickupexten = *8 ; Configure the pickup extension. Default is *
;featuredigittimeout = 500 ; Max time (ms) between digits for
; feature activation. Default is 500

blindxfer => #1 ; Blind transfer
disconnect => #0 ; Disconnect
automon => #3 ; One Touch Record
atxfer => #2 ; Attended transfer

; Note that the DYNAMIC_FEATURES channel variable must be set to use the featur
; defined here. The value of DYNAMIC_FEATURES should be the names of the featu
; to allow the channel to use separated by ‘#’. For example:
; Set(DYNAMIC_FEATURES=myfeature1#myfeature2#myfeature3)
;testfeature => #9,callee,Playback,tt-monkeys ;Play tt-monkeys to
;callee if #9 was pressed


I have not made any entries in the extensions.conf that could have anything to do with DTMF or call transfering. Maybe I’m just missing those entries in my extensions.conf?

Help will be appreciated!


blindxfer => # ; Blind transfer
;disconnect => *0 ; Disconnect
;automon => *1 ; One Touch Record
;atxfer => *2 ; Attended transfer

try replacing this, it works perfectly fine with me. and check your capi conf files as well…
if it works then ill let u know what you were doing wrong… :smile:

show us the Dial command you’re using … unless there’s a ‘T’ or a ‘t’ in the options, Asterisk won’t be listening for a transfer request.

also, check your DTMF settings. if not configured correctly, Asterisk won’t pick up the tones and start the transfer process.

It seems that it was a bad idea to have entries like this in the dialplan:

I don’t know if that was the cause, but since I changed that, DTMF is being accepted.
Not that I don’t have any more problems with my dialplan, but I think I can go on now.

Thanks a lot!