Blind Transfer Issue

Hi everyone

I hope you guys can help me with blind transfer.
I’m going to exemplify I hope in the most clear way.
I’ve with 4 users (extensions) two of them are A, B, let’s suppose A and B are in a call or talking each other, I also have two other users C, D. C receive an incoming call and decide to transfer to A or B, but as I said A and B are busy because they are talking each other or attending a call.
Here is the problem, when I want to transfer a call, for example C make a call to D then D decide to transfer this call to A ::::: ##A ::::: then asterisk disconnect both users and sounds busy tone.

I don´t know why but it only happen using ## not **
Does anybody here can help me ?
Best regards.

This how I have features.

[code][general]

parkext => 700
parkpos => 701-710
context => parkedcalls
parkingtime => 45
findslot => next
;Esto es nuevo ¬
courtesytone = beep
parkedplay = caller
parkedcalltransfers = caller
parkedcallreparking = caller
parkedcallhangup = caller
parkedcallrecording = caller
parkeddynamic = yes
adsipark = yes
atxfercallbackretries = 2
featuredigittimeout = 5000
transferdigittimeout => 3
comebacktoorigin = yes
comebackdialtime = 30
;************************************************

comebackcontext = parkeada
atxfernoanswertimeout = 15
atxferdropcall = yes

;************************************************

xfersound = beep ; to indicate an attended transfer is complete
xferfailsound = beeperr ; to indicate a failed transfer
pickupexten = *8 ; Configure the pickup extension. (default is *8)
pickupsound = beep ; to indicate a successful pickup (default: no sound)
pickupfailsound = beeperr ; to indicate that the pickup failed (default: no sound)
;featuredigittimeout = 1000

[featuremap]
blindxfer => ## ; Blind transfer (default is #) – Make sure to set the T and/or t option in the Dial() or Queue() app call!
disconnect => *0 ; Disconnect (default is *) – Make sure to set the H and/or h option in the Dial() or Queue() app call!
automon => *1 ; One Touch Record a.k.a. Touch Monitor – Make sure to set the W and/or w option in the Dial() or Queue() app call!
atxfer => ** ; Attended transfer – Make sure to set the T and/or t option in the Dial() or Queue() app call!
parkcall => #72 ; Park call (one step parking) – Make sure to set the K and/or k option in the Dial() app call!
automixmon => *3 ; One Touch Record a.k.a. Touch MixMonitor – Make sure to set the X and/or x option in the Dial() or Queue() app call![/code]

This is what CLI shows to me.

[code]Connected to Asterisk 11.4.0 currently running on dell9150 (pid = 1029)
== Using SIP RTP CoS mark 5
– Executing [2007@users:1] Dial(“SIP/2009-00000002”, “SIP/2007,20,tTrKHW”) in new stack
== Using SIP RTP CoS mark 5
– Called SIP/2007
– SIP/2007-00000003 is ringing
– SIP/2007-00000003 is making progress passing it to SIP/2009-00000002

0xb6f0f2a8 – Probation passed - setting RTP source address to 192.168.1.132:20
– SIP/2007-00000003 answered SIP/2009-00000002
0xb6f0f2a8 – Probation passed - setting RTP source address to 192.168.1.132:20
0xb6e275e0 – Probation passed - setting RTP source address to 192.168.1.111:6066
== Using SIP RTP CoS mark 5
– Executing [2004@users:1] Dial(“SIP/marcos-00000004”, “SIP/dish,20,tTrfkwhx”) in new stack
== Using SIP RTP CoS mark 5
– Called SIP/dish
– SIP/dish-00000005 is ringing
– SIP/dish-00000005 is making progress passing it to SIP/marcos-00000004
0x9577960 – Probation passed - setting RTP source address to 192.168.1.244:6010
– SIP/dish-00000005 answered SIP/marcos-00000004
0x9577960 – Probation passed - setting RTP source address to 192.168.1.244:6010
0xb6e5fa00 – Probation passed - setting RTP source address to 192.168.1.147:6114
– Started music on hold, class ‘default’, on SIP/marcos-00000004
– <SIP/dish-00000005> Playing ‘pbx-transfer.gsm’ (language ‘en’)
– Blind transferring SIP/marcos-00000004 to ‘2007’ (context users) priority 1
– Stopped music on hold on SIP/marcos-00000004
– Executing [2007@users:1] Dial(“SIP/marcos-00000004”, “SIP/2007,20,tTrKHW”) in new stack
== Using SIP RTP CoS mark 5
– Called SIP/2007
– Got SIP response 486 “Busy Here” back from 192.168.1.132:5060
– SIP/2007-00000006 is busy
== Everyone is busy/congested at this time (1:1/0/0)
– Auto fallthrough, channel ‘SIP/marcos-00000004’ status is 'BUSY’
dell9150*CLI>
[/code]

I’m sorry about my english.
Thank you

Hi, elarquitecto, as you have been pointed in the other forum That is not an issue, that is the normal behaviour of a blind transfer you need to create your own dialplan to handle the call and return it to your previous device, here is the example that Hector share in the other forum just adapt to your needs:

asterisk.org.za/pipermail/tech/a … chment.obj

I’ll look at this link again, to be honest I already seen in it but I get confused each time I see it., I do not understand it. anyway thakyou.

HELP !!! :smiley:

Regards !