Remote x-lite incoming audio issues

I am having a remote x-lite incoming audio problem. On the local network there is x-lite with their own 4-digit extensions on two wireless laptops and they work fine, and I also have a cisco 7960 IPphone with 6 4-digit extensions which also works fine. The problem is that on the remote computer with x-lite 2.0 also with its own 4-digit extension they can hear me but I cannot hear them. We have tried several configuration changes to no avail. Their computer runs windows xp and is connected directly to the cable modem thus connected directly to the internet, my local network is behind a Linksys WRT54G router. I have SIP ports 5060 - 5082 and RTP ports 8000 - 8020 forwarded to my asterisk server. This same asterisk server is used with internal extension calls and external calls to and from the PSTN through my ITSP. On yahoo messenger with voice we both speak fine and when I call the remote x-lite from my cell phone we can talk with no problems, so I don’t know what the issue is with x-lite or is it an asterisk thing? This x-lite also registers with the same asterisk server as the rest of the bunch. We’ve tried totally disabling firewalls on both ends with no effect. I appreciate any suggestions.

Thanx for looking and perhaps racking your brains. I finally got it to work flawlessly by doing a whole bunch of different stuff from RTP port forwarding to the asterisk server, editing rtp.conf with the appropriate rtp port(s), editing sip_nat.conf with the WAN and local IP settings and also adding some nat settings to the remote extension account in sip.conf. For full config info, see my posting at