One way audio, Internet Call over NAT


#1

I am trying to use X-lite over the Internet and dial an X-lite extension behind my Asterisk@Home server. I can get them to connect but I cannot here the far end extension talking but they can hear me. Below is my setup in my asterisk box. I also have the following ports forwarded from my Linksys router to my *box.

10,000 to 20,000 UDP/TCP
6061 to 6061 UDP/TCP
4569 to 4569 UDP/TCP
5004 to 5082 UDP/TCP

Edit: sip_nat.conf
nat=yes
externip=XXX.XXX.XXX.XXX
localnet=192.168.1.125/255.255.255.0

And in my extensions I have

NAT=Yes
Qualify=Yes

Any help would be appreciated…


#2

Are they able to call you? From outside your network, are you on a firewall that might be blocking you?

I would grab and IAX softphone and try that instead of SIP and see if you have better luck. IAX phone configures the same way, just uses a different protocol that, for the most part, will slither its way through a firewall very very well.


#3

Yes they are able to call my extension, I would rather try to keep using SIP because I have a Cisco 7960 working on the * system. The only reason I am trying to use 2 X-ten soft phones is simplicity on not testing with that pain in the @56$$#$ Cisco phone. LOL…

Any suggestions??


#4

can you briefly put the remote extension onto the DMZ to see if that relates to the issue. Also - what is the remote router? The local router? Are there any settings on either such as an “Application Level Gateway - ALG” or equivalent that tries to be smart with SIP? (You see these on SOHO routers). I’ve seen checking SIP create this problem.

In either case - do the DMZ test at the remote end if you can, and if the problem still exists, do it on the Asterisk end. (briefly in both cases, just a sanity test to help isolate where you need to dig further - and preferably put up the firewall on Asterisk if you need to do it on the Asterisk end).

p

p.s. - do you have canreinvite=no? - if not, what is the default?


#5

I turned DMZ on the Asterisk side and pointed it towards the Asterisk itself and it worked?? What port am I missing?? Also canreinvite= NO.

Thanks


#6

normally if you have udp 5004 (not always needed), 5060-5080 and 10K-20K (or what ever matches your rtp.conf settings) you are ok.

However, I had a very similar problem with a SOHO router I had purchased a few weeks ago (DLINK 634M I think it was). I returned it the next day but someone on the AAH forum had posted how they pulled their hair out and finally got it working, something in the gaming area. (They had thrown away the packing material, I hadn’t:)

I replaced that modem with another SOHO Zyxel X550 router. If you check the ALG SIP setting, it breaks with a similar problem. If you un-check it and just forward the ports properly you are ok. (But in Xyxel case, to their credit, they documented that the SIP setting might break things and you might have to turn it off).

anyhow - it’s either figure out how to get it to work on your router, replace the router, or put up the firewall, lock up everything, make sure you are content and leave it on the DMZ…

p


#7

I had a similar issue but with Aastra 9113i’s. The phones would connect but were unable to hear any sound.

In my case I found that I had locked down the linux kernel to tightly using ipchains. I needed to open up the kernel firewall to allow packets with UDP source port of 3000. This seems to have solved it.

Hope this helps

UnderMine


#8

hi

even i tried this it was one way for me also but only in linux
but in linux i failed to clear echo test
and also if i call to the user who had registered to free sip provider he was able to hear me
but i cant hear him
if he calls me i can hear him but he cann’t
i guess something problem with the nating

but in windows it was two way
i was able to finish echo testproperly

if any tells solution plz do remind me