X-lite softphones ---> Can receive but can't transmit

In the LAN (same subnet as the asterisk server)… I can use the soft phone for whatever I want.

But over the internet… I can only recieve.

What exactly are the specific requirments to accomplish a long range connection to a Asterisk Server?

IE: Firewall rules.

I’ve already searched and searched and searched…so far I still get the same problem.

I don’t think its X-lite as it’s worked fine in the office.

im not sure if this will help but here goes:

setup in our office
internet > firewall/nat box > workstations
> wifi (dhcp/nat) > wireless laptops

all those laptops were not able to send voice but can hear.

Errr… no.

While in the office… the computers on the same subnet… can send receive … anything outside of that subnet… can only recieve.

that meaning send being transmit and receive being hearing.

But your layout does give me some thought as to possible causes.

First if you are using NAT make sure that in sip.conf you have NAT=YES as well as externip set to your IP or dynamic DNS. Next you have to forward ports 5060-5090 and 10000-20000 UDP to your server. If you have a public IP on the box and just a firewall then you will need to open the same ports as mentioned above.

What are ports 10000 to 20000 UDP for per chance?

RTP. SIP uses two sets of ports, 5060 is for SIP itself and is the control channel. The media (voice data) is sent over RTP which requires a range of ports. 10k-20k is the default and is set in rtp.conf.

Oops :confused:

I guess that might explain why I can hear but not send.