Reduce Call Waiting on Queue

I am having a queue with around 45 static agents and using ‘rrmemory’ as strategy. What we feel there is more call waiting duration usually around above 60 seconds. Although agents are free and available for taking calls but Queue don’t forward the calls to free agents and it takes usually 60+ sec to forward.
I already apply settings
memberdelay=2 on Queue
for 2 sec delay only but it don’t help to reduce the call waiting time.
any hints or suggestion in this regard would be appreciated.

Check your wrapup time.

Hi there,
already have
wrapuptime = 0
but did not give the desire result…
any others recommendation or suggestion please.


What have you got AutoFill set to?

[quote]; The old/current behavior of the queue has a serial type behavior in that the queue will make all waiting callers wait in the queue even if there is more than one available member ready to take calls until the head caller is connected with the member they were trying to get to.
; The next waiting caller in line then becomes the head caller, and they are then connected with the next available member and all available members and waiting callers waits while this happens.
; The new behavior, enabled by setting autofill=yes makes sure that when the waiting callers are connecting with available members in a parallel fashion until there are no more available members or no more waiting callers.
; This is probably more along the lines of how a queue should work and in most cases, you will want to enable this behavior.
; If you do not specify or comment out this option, it will default to no to keep backward compatibility with the old behavior.[/quote]

Thank you for the reply here is my queues.conf file settings




I am using autofall=yes in general settings

please suggest/recommendation.



Is that ALL your queues.conf has in it ?? what about retry time, etc etc check the sample file for your version for the settings avalible,