Realtime mysql sippeers

Howdy all,

I’m trying to get realtime setup with mysql so i can register uses/peers via the database.

here is what i’m running:-

  • centos 6.6 64bit
  • Asterisk 11.14.1
  • mysql Server version: 5.1.73
  • installed asterisk-addons so res_mysql is installed and running no problems

I’ve setup the database and the sippeers table as per the structure in the contrib folder

Asterisk is running no problems.

realtime mysql status shows the user setup in res_config_mysql is connected

contents of res_config_mysql

dbname = asterisk
dbhost =
dbuser = user-i-created-here
dbpass = password-here
dbport = 3306
dbsock = /tmp/mysql.sock

contents of extconfig.conf is

extensions => mysql,general,extensions
sipusers => mysql,general,sipusers
sippeers => mysql,general,sipusers
sipregs => mysql,general,sipregs

contents of sip.conf is


mysql database/tables

mysql> show databases;
| Database |
| information_schema |
| asterisk |
| mysql |
3 rows in set (0.00 sec)

mysql>use asterisk

mysql> show tables;
| Tables_in_asterisk |
| extensions |
| sipregs |
| sipusers |
3 rows in set (0.00 sec)

Now what happens when i populate a the sip sipusers table with some info like defaultuser, password (not using md5 here) etc is i just get constant rejections for “wrong password” in the console.

Registration from ‘"100"sip:100@’ failed for ‘’ - Wrong password

The password is correct, it’s a very simple password while testing this out.

Can anyone point me in the right direction?

So i swapped over to odbc (i should have been using this anyway) and I’ve managed to get static realtime working with sip.conf but i’m still not able to get dynamic working so i’m unable register and extension, i just get the same error every time. Nothing else in the console with verbose up to 99 and logger set to log everything to console.

Can anyone point me in the right direction here, anyone?

Sorted this out, i was missing the column “mask” in my sipusers table, once that was inserted and populated it was good to go!