[SOLVED] Realtime configuration problems


#1

Hello!
I’ve tried to configure my asterisk to read configurations using mysql realtime driver but they don’t get any sipusers or sippeers configurations from database. I’ts seems to work just with extensions configs (that i’ve tested).

My configs:

res_mysql.conf 

[general]
dbhost = 127.0.0.1
dbname = asterisk
dbuser = root
dbpass = root
dbport = 3306
extconfig.conf 
[settings]
extensions => mysql,general,asterisk_extensions
sipusers => mysql,general,sippeers
sipppers => mysql,general,sippeers
realtime mysql status
general connected to asterisk@127.0.0.1, port 3306 with username root for 8 seconds.

I’ve created my tables on mysql according with contrib/realtime/mysql scripts.

== Using asterisk 15

I don’t see any errors on asterisk logs related to the database.
I’ve created the sip user on the table but when i try to login on client, i get wrong password message from asterisk.


#2

I haven’t tried realtime recently but I think you have typo here.

sipppers should be sippeers


#3

Thank you so much!
Really it’s a typo, hard to seen that! It’s work great now!