Question on *@home


#1

Hi,

I installed *@H and everything is going fine. Yesteday, I also installed a TDM400P and got connected to the PSTN and I can succesfully make and receive calls via this connection. However, there are two problems that I would like to resolve.

First, when I receive a call, the connection to the Phone (an IP phone) is only established after 5 to 10 seconds (the first ring is heared after 5 to 10 seconds).

Secondly, when the caller hangs up (before any answer from the IP phone) the line remains busy until unhooking the Ip phone or until the voicemail finishes registering.

Can somebody give me some pointers on how to get rid of these anomalies.

Thanks in advance,

Daniel.


#2

it sounds as if you haven’t set your zap configs correctly for your location yet. you need to know your telco signalling type and modify /etc/zaptel.conf and /etc/asterisk/zapata.conf (plus the A@H zap files) accordingly. you also need to make sure you load wctdm in the right mode for your location.

if you’re not using fxs ports on your tdm, and you don’t have/care about CallerID (or live somewhere that presents callerid before the first ring) then in /etc/zapata.conf you can set immediate=yes to get rid of the ring delay.


#3

Thank you for your prompt response.

I set “immediate=yes” in zapata.conf and it works; thanks for that.

But, may you please give me some explainations on the signalling type? For the moment in “zapata.conf” the signalling is set to fxs_ks and in zapata_additional.cong" to kxo_ks.

By the way, how to load the wctdm in the right mode? What I do for loading it is “modprobe wctdm”. Is it correct?

Daniel


#4

without knowing your location or telco … different telcos use different signalling methods. loopstart and kewlstart are the faves. but you need to know which you have to setup remote disconnection properly.

here in the UK we use kewlstart, and it’s been fun and games getting a TDM to work correctly. but it’s ok now i’m using HEAD, hence me asking which build you are using.

what country are you in ? (geez, i wish people would fill in at least that part of their profile !!) what does /var/log/dmesg record for the module load ?


#5

Thanks again,

I live in Belgium.

Daniel


#6

it’s like extracting teeth here !!!

if your system uses /etc/modprobe.conf try adding options wctdm opermode=BELGIUM, then unload and reload the wctdm module. then, like i asked earlier, post the relevant entries from /var/log/dmesg


#7

My modprobe.conf is located in /etc/log.d/conf/services. Anyway, I did exactly what you said but I didn’t find anything relevant to wctdm in /var/log/dmesg.

What is wrong?

Daniel


#8

my apologies, i’ve got dmesg on the brain today. can you look at /var/log/messages instead :smiley:


#9

sorry, but still nothing relevant to wctdm

Daniel


#10

my apologies. This time it’s me. I looked again at /var/log/dmesg.

Yes, there are the following lines:

Nov 15 16:01:03 asterisk1 kernel: Freed a Wildcard
Nov 15 16:01:09 asterisk1 kernel: Freshmaker version: 73
Nov 15 16:01:11 asterisk1 kernel: Module 0: Installed – AUTO FXS/DPO
Nov 15 16:01:11 asterisk1 kernel: Module 1: Installed – AUTO FXS/DPO
Nov 15 16:01:11 asterisk1 kernel: Module 2: Installed – AUTO FXO (FCC mode)
Nov 15 16:01:11 asterisk1 kernel: Module 3: Installed – AUTO FXO (FCC mode)
Nov 15 16:01:11 asterisk1 kernel: Found a Wildcard TDM: Wildcard TDM400P REV I (4 modules)
Nov 15 16:01:11 asterisk1 kernel: Registered tone zone 17 (Belgium)

Apparently the last line does not correspond to what I added to “modprobe.conf”, because It also appears in /var/log/messages when "options wctdm opermode=BELGIUM is not set in modprobe.conf

regards,

Daniel


#11

what distro are you using ? and kernel ?

my output says (UK mode) when wctdm loads, so i was expecting to see something related to your locale. you need to modify the options passed to the module when loading.

did you manage to find out your signalling type yet ?

are those realy FXS modules on ports 0 and 1 ? if so, and you connect handsets to them, i think you’ll find that immediate=yes causes problems.

once you have the module loading with the right locale setup, and you’ve set your tonezones, and you know your signalling type, you can then modify/tweak zapata.conf and zaptel.conf.


#12

Hi,

I use the CentOS distribution and the kernel 2.4.21 as provided by *@H.

I don’t know what the FCC mode does mean, but certainly it has nothing to do with my location. I reviewed and tried all options with modprobe but nothing changes in the output. Do you have any idea?

The signalling type used in belgium is kewlstart (neither loop nor ground start work correctly) but I don’t understand why it doesn’t work in my case.

FXo and FXS channels are correct and I do not have any problem with immediat=yes.

I cannot find what is the right local setup as, except the zonetone (that I set to “be”), I do not find anything relevant to the location. May it be about the signal frequencies or something like that, that should be modified somwhere in onfig files?

regards,

Daniel


#13

I just loaded the wctdm with opermode=BELGIUM as option and got “AUTO FXO (BELGIUM mode)” as output. However the problem still persists.

daniel


#14

hi, IME, tweaking zapata.conf only gets you so far, the biggest change for me (we use kewlstart here) was the opermond=UK addition to an options line in /etc/modprobe.conf. looking at just a small part of wctdm.c shows settings for belgium to be substantially different to FCC (US and canada) settings. what’s even more puzzling is the fact that belgium (and UK) is also noted as using TBR21 !!

for reference, i’ve dug out an A@H-based config that i know works properly on UK kewlstart signalling. i’ve removed the UK-specific bits for CallerID as BT use their own “weird delivery mechanism” (so digium tell me)

[channels] language=en context=from-pstn signalling=fxs_ks rxwink=300 usecallerid=yes callerid=asreceived useincomingcalleridonzaptransfer=yes hanguponpolarityswitch=no busydetect=yes ;busycount=3 ;callprogress=no hidecallerid=no callwaiting=no usecallingpres=yes callwaitingcallerid=no threewaycalling=yes transfer=yes cancallforward=yes callreturn=yes echocancel=yes echocancelwhenbridged=yes echotraining=yes rxgain=2.0 txgain=-1.0 group=0 callgroup=1 pickupgroup=1 immediate=yes progzone=uk faxdetect=no

in theory (i think !) i should be using hanguponpolarityswitch=yes busydetect=no; or commented outbut this setup works and i’m loathe to change it.

i’d like to buy digium hardware, but the “black magic” side of Zap worries me. i know the UK userbase is much smaller than across the pond, but it would be nice to have some definitive settings for non-US use. then again, it’s something else to do :smiley: and i want to buy a 2400 with echocan to play with.


#15

By putting

hanguponpolarityswitch=yes
busydetect=yes

in zapata.conf, it seems to work. However, now the specification

immediate=yes

has no more effects. Is there a conflict between these two?

daniel