[Help] ZAP channel answers call prematurely

Hi all, I apologize if this has been answered before, but I searched and couldn’t find it.

I have a TDM400 with 2 FXO modules, running Asterisk 1.2.10 and FreePBX (AMP). I only have one pots line connected to channel 4. Incoming calls work fine. But when I dial out on ZAP/4, one of two things happens:

  1. I hear one ring from Asterisk, then the call is answered prematurely and I hear silence for 20 seconds, then I hear “Your call did not go through” message broadcast from the TDM side.

  2. I hear one ring from Asterisk, then the call is answered prematuredly and I hear ringing from the TDM side until the called party picks up the call (I can tell the rings are different because the first Asterisk ring is clear and TDM rings are not as loud)

Here is my zapata.conf code:

channel => 4

Here is my Zaptel.conf code:

loadzone = us

PS: Some of the lines in my zapata.conf are commented out because I tried to add them, but they didn’t help. I even tried loopstart instead of kewlstart with no joy. I also tried channel 3 in case I had a defective FXO module on channel 4, but I get the same undesirable results.

Is there a way to stop Asterisk from answering outbound calls prematurely?

Thanks in advance,

I did more testing and found that the reason I was unable to dial out is because Asterisk was dialing the outgoing number too quickly and not giving the PSTN time to listen to dialed digits. So I searched the forum and found someone already had a solution for this… here is a copy of posting:

[quote]In your extensions.conf, try putting 3 w’s before the number you’re
trying to dial, eg

exten => 1234,1,Dial(Zap/1/www5551212)

instead of

exten => 1234,1,Dial(Zap/1/5551212)

Each ‘w’ adds 500 ms of delay before asterisk begins to dial. This is
necessary for some users because asterisk doesn’t wait for
acknowledgement from the remote end that the offhook was sensed.
Asterisk begins to dial as soon as it takes the line offhook, and if the
telco isn’t yet aware of the offhook condition of the line, it doesn’t
know to be listening for digits to dial. Delaying a second or so will
generally resolve this problem.[/quote]

Now I still have a problem with Asterisk prematurely switching from Ring to Talk mode when I set callprogress=no. If I set it equal to yes, then Asterisk keeps Ringing and never goes to Take mode even when called party answers calls.

Is this normal behavior for TDM400 card or am I still missing a piece of the puzzle?

Thanks again,