Digium TDM400 card answering incomming PSTN calls


#1

Hi,

I just put our TDM400 card (with 4 FXO ports) in our Asterisk @ Home box. I called our land line number from my mobile, and my VoIP phone rang, as it was ment to.

However when i call the PSTN number, it takes 2-3 rings before Asterisk even tried to pick up the line, and then when it does its another 1-2 seconds before my extension starts to ring.

Can this be fixed at all? So the extension rings as soon as the PSTN line rings, or as close as possibe?

Thanks in advance,
Adrian


#2

boy, do i wish people would indicate in their details where they are :smiley:

the delay is so that Asterisk can get CallerID in the US (and where they use the same CID protocols), where the data comes through sometime in the first 3 rings.

in the UK we get CID before the first ring, so in zapata.conf i can set immediate=yes to get Asterisk to ring immediately. of course, you can’t use this if you also have FXS modules installed.


#3

[quote=“baconbuttie”]
in the UK we get CID before the first ring, so in zapata.conf i can set immediate=yes to get Asterisk to ring immediately. of course, you can’t use this if you also have FXS modules installed.[/quote]

Why you can’t use this if you have FXS module installed?


#4

'cos the immediate=yes means that as soon as you pickup the phone connected to the FXS port, it will be connected to the ‘s’ extension of the appropriate context. from voip-info


#5

[quote=“baconbuttie”]boy, do i wish people would indicate in their details where they are :smiley:
[/quote]

Sorry My Bad. I’m from downunder (Australia).

We dont have caller id enabled on the line, so thats not important