PSTN line answer to long


#1

Hello,

I am using the beta version 1.2 of asterisk and an FXO card (X100P).
Currently I have the following problem: when I call my incoming line
Asterisk does not answer immediately. It answers after 3-10 rings and
displays “CallerID returned with error on channel ‘Zap/1-1’”.
Sometimes it answer once I hunged up the phone.

I think that my zapata.conf file is correct. The parameter immediate is set to yes.

Can anybody help me?
Should I use the version 1.0.9 of Asterisk instead?

Thank you in advance.

Laurent


#2

If the line callerid=yes in zapata.conf is set to “no”, your system should answer the line after the first ring. If set to “yes” it will wait until the second ring, because the caller ID info is sent between the first and second rings.


#3

That should be usercallerid=no/yes in the previous response. I’m not at home to look at my system, and was responding from memory (which isn’t always reliable).


#4

Hello jebradley,

The problem is that my phone does not answer in the second ring. It can answer at the 7th or 10th ring. Since a route my PSTN calls to a SIP user sometime the SIP phone calls once 6 have already hanged up the phone. I am going to try with the option ‘usecallerid=no’ .

However I am sending you the configuration that I am currently using.
Just one more question, I am using the beta version of Asterisk 1.2 but I am planing to use it in a production environment what do you suggest me?

; zapata.conf

[channels]

language=fr
context=pstn_incoming

immediate=yes

;switchtype=national
signalling=fxs_ks
rxwink=300

usecallerid=yes
hidecallerid=no

callwaiting=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes

group=1
channel=>1

Thanking you in advance,

Laurent


#5

I would suggest a stable release, such as 1.5, before I would deploy a “Beta” release into production.