PSTN calls are delayed


#1

I have a P4 w/256MB DDR running Asterisk@Home 1.5. There are two PSTN lines that come into a TDM400P card. The handsets are Sipura 841 SIP phones.

Every time a call comes in, it rings on the callers end for about 9 seconds then there is an audible click and 2 seconds of silence, then ringing starts again.

After the 2 seconds of silence is when the office phones ring. If I turn off the ring group and have the digital receptionist pick up there is no silence and the connection is imediate. Problem is, the boss does feel the digital receptionist should answer the phone.

We used to have this setup on a P2 w/128MB SDRAM and the silence was more like 25 long before the office phones would ring. Is this not so seamless connection just a function of machine speed? Or did I goof something in my config?

Thanks for any help at all you can offer.


#2

Yeah i was looking for this solution too. I did some research on the extensions.conf and i found some Wait(3) on the dial plan. Issit too much of waiting in the dial plan or …?? :confused: :confused:


#3

Depending on the country you’re in, (specifically in the US) the callerID information is delivered between the first and second rings.

Because of that, if you use callerID, the system won’t have all the necessary information to start the stations ringing, or start any other services, until after the second ring begins. That’s your first 6 or 7 seconds.

If you have the Answer() and Wait() commands before your digital receptionist, they will start the “second ring” and “2 seconds of silence” that you notice.

To fix this particular problem you’d need to get ISDN lines instead of analog lines. When calls are delivered, Asterisk will be able to answer immediately, as all of the callerID data is delivered at the same moment that the call arrives.

Alternatively, you can tell Asterisk to ignore the fact that you have callerID, and just answer immediately, but you lose the incoming caller data that might need.


#4

Thank you for your help. Turning off caller id in zapata.conf did the trick. I changed usecallerid=yes to usecallerid=no and tried a couple of calls in. They all rang once on the caller end and then the office phones started ringing by the time the caller heard the second ring.

Oddly enough though caller id is still coming through on the phones even though I turned it off in asterisk. I wonder if the phone remebers the phone number or if it’s coming from our PSTN provider.

Anyway, thanks again!


#5

Also, turn off Fax detection. The delay is usually caused by AAH listening for a fax tone if fax detection is enabled.


#6

set immediate=yes on trunks. this stops the 2 second delay for callerid. Don’t set immediate=yes on FXS ports though, otherwise you will get no dialtone.