Problems in playing .gsm sample sound files in calls

I’ve got Asterisk PBX system consisted of 2 SIP clients (X-Lite softphones running on Win XP). Calling and voice transmission in calls works OK, but I got problems in playing .gsm sample sound files in the call.

I’ve set up auto answer with playback of some .gsm sound file on one extension and when I call that extension, it automatically answers but plays that sound file extremely bad, with mumbling instead of real sound. When I change the played sound file, I just got another, different mumbling. I’ve realized that function of playing files goes OK, but only with the extremely low quality, the voice recorded in the file is unrecognizable.

Any possible solutions to the issue?


Hi all,

I am facing the same issue with AsteriskNOW 1.0.2 with GUI2.0.
The PC I am using is a 800MHz AMD with 384MB RAM.

Analyzing the output of “show modules” CLI command it seems that the issue is related to the Only when this format is active the sound is bad. Playing a .WAV (the default for music on hold) works great.
Calls with both GSM and G.711 (alaw) also works great.

I checked the load on the CPU (~5%) and the free RAM is 100MHz.
I also suspect the slow hard disk access

Help is appreciated.


Playing a .wav file in my setup also makes a problem. I realize that this all issue is related to something about codecs, but I don’t know what. It seems that my Asterisk doesn’t play sound files well :frowning: I didn’t make any changes to other sample files besides extensions.conf and sip.conf .

I run Asterisk on AMD 64 Athlon X2.

Anyone have a clue?

I have read that some of this issue is from compiling gcc
If you search the forum for gsm and gcc, you may find an answer on it
sorry I just didnt have time to do the search for you

Try first to record your files in wav format and then you have to use a tool called SOX to convert your files into GSM using this command:
sox foo.wav -r 8000 -c 1 foo.gsm after downloading it.
you can download it from here: … p_id=10706

I have seen some possible solutions on other topics, and:

  1. I have tried to play .wav files instead of .gsm files: didn’t solve the problem
  2. I have installed Asterisk with DONT_OPTIMIZE checked in make menuselect (using gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)): didn’t solve the problem


Any other possible solutions?