Polycom Stuck in Reboot

Hi All,

I hope someone has an answer out there for why my phones will not connect/provision correctly.

New Linux Install. Asterisk 1.8 Running. Dialplans all work, DAHDI cards working, soft phones work great. I cannot get my Polycom phones to provision. I have a combo of Soundpoint 430 and 330.

Polycom phones have never been connected to another asterisk system. Have been sitting in boxes waiting.
FTP Server: ProFTPD
DHCP Setting Options.
SIP version 3.2.3
Boot Rom 4.2.2

The phone boots up, connects, seems to get all the right information, downloads the config file. Gets to the point of running sip.ld and then just reboots.

Here is the boot log file:

[ul]0117042734|copy |3|00|Upload of ‘0004f214f016-boot.log’ succeeded on attempt 1 (addr 1 of 1)
0100000000|so |4|00|---------- Initial log entry ----------
0100000000|so |4|00|+++ Note that bootrom log times are in GMT +++
0100000000|cfg |4|00|Initial log entry
0100000000|copy |3|00|Initial log entry
0100000000|hw |4|00|Initial log entry.
0100000000|ethf |4|00|Initial log entry.
0117042733|wdog |4|00|Initial log entry
0117042733|lldp |3|00|LLDP is DISABLED.
0117042733|cdp |3|00|CDP is DISABLED.
0117042733|so |3|00|Platform: Model=SoundPoint IP 430, Assembly=2345-11402-001 Rev=C
0117042733|so |3|00|Platform: Board=2345-11402-001 1
0117042733|so |3|00|Platform: MAC=0004f214f016, IP=Resolving, Subnet Mask=Resolving
0117042733|so |3|00|Platform: BootBlock=2.7.0 (11402_001) 18-Apr-06 10:24
0117042733|so |3|00|Application, main: Label=BOOT, Version=Biotite 24-Feb-10 16:41
0117042733|so |3|00|Application, main: P/N=3150-11069-422
0117042733|app1 |4|00|Initial log entry.
0117042734|so |3|00|Link status is Net down, PC down.
0117042735|so |3|00|Link status is Net up Speed 100 full Duplex, PC down.
0117042735|lldp |3|00|Enabling 802.1Q tagging, VLAN ID = 30 (from FLASH)
0117042735|lldp |5|00|VLAN Id has changed to 30.
0117042744|lldp |3|00|LLDP did not receive a response from a switch. Disabling LLDP.
0117042747|cdp |3|00|CDP received a response from a switch. CDP enabled.
0117042747|cdp |3|00|Native VLAN Id is 40
0117042747|cdp |3|00|No Auxiliary VLAN found
0117042747|cdp |3|00|CDP power usage is 4500 milliWatts.
0117042820|app1 |3|00|DNS resolver server is '’
0117042820|app1 |3|00|DNS resolver search domain is 'csc.local’
0117042820|app1 |3|00|Bootline: esw(3,0)bootHost:flash e= h= g= u=**** pw=**** f=0x40 tn=CircaIP
0117042820|app1 |3|00|DHCP returned result 0x2EF from server
0117042820|app1 |3|00| Phone IP address is
0117042820|app1 |3|00| Subnet mask is
0117042820|app1 |3|00| Gateway address is
0117042820|app1 |3|00| Boot server address is
0117042820|app1 |3|00| Time server is
0117042820|app1 |3|00| GMT offset is -18000 seconds.
0117042820|app1 |3|00| DNS server is
0117042820|app1 |3|00| DNS domain is csc.local.
0117042826|app1 |3|00|Time has been set from (
0117042826|cfg |3|00|Beginning to provision phone
0117042826|copy |3|00|‘ftp://cscphone:@’ from '’
0117042826|cfg |3|00|Image 2345-11402-001.bootrom.ld has not changed
0117042826|copy |3|00|buffered_write: transfer terminated
0117042826|copy |3|00|Download of ‘2345-11402-001.bootrom.ld’ succeeded on attempt 1 (addr 1 of 1)
0117042826|cfg |3|00|Downloaded bootROM is identical to current version 4.2.2
0117042826|copy |3|00|'ftp://cscphone:
@’ from '’
0117042832|copy |3|00|Download of ‘0004f214f016.cfg’ succeeded on attempt 1 (addr 1 of 1)
0117042832|copy |3|00|‘ftp://cscphone:****@’ from '’
0117042832|cfg |3|00|Image 2345-11402-001.sip.ld has not changed
0117042832|copy |3|00|buffered_write: transfer terminated
0117042832|copy |3|00|Download of ‘2345-11402-001.sip.ld’ succeeded on attempt 1 (addr 1 of 1)
0117042832|cfg |3|00|Downloaded application image is identical to current version
0117042832|cfg |3|00|Phone successfully provisioned
0117042832|app1 |3|00|Application, load: Type=SIP, Version= 22-Mar-10 16:50
0117042836|app1 |4|00|Loaded application sip.ld successfully, errors 0x0.
0117042836|app1 |6|00|Uploading boot log, time is MON JAN 17 04:28:37 2011[/ul]

[ul]<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<!== Revision 1.0 $ $Date: 2009/10/23 13:53:00 $ -->


[ul]<?xml version="1.0" encoding="utf-8" standalone="yes"?>


[ul]<?xml version="1.0" standalone="yes"?>

<server voIpProt.server.1.address="" voIpProt.server.1.port="5060" voIpProt.server.1.transport="UDPOnly" voIpProt.server.1.expires="3600" voIpProt.server.1.register="1" voIpProt.server.1.retryTimeOut="0" voIpProt.server.1.retryMaxCount="0" voIpProt.server.1.expires.lineSeize="0" <outboundProxy voIpProt.SIP.outboundProxy.address="" voIpProt.SIP.outboundProxy.port="5060 /> </SIP> </voIpProt> <sip>[/ul] <p>The sip.cfg and phone1.cfg are stock from Polycom site, no changes made. Also 0000000.cfg is stock as well.</p> <p>Things I have tried:</p> <p>Setting all network settings to Static IP.<br> Using Stock Polycom Settings. Just renamed 000000.cfg to mac.cfg with no other changes, still does the same thing. Gets to Running sip.ld and reboots<br> Erased flashed numerous times.<br> Upgraded, downgrade SIP.</p> <p>I have tried and read so many things. I hope I have just missed something simple, but I am at a loss as to what the problem is.</p> <p>Any help or pointers would be greatly appreciated.</p> <p>Matt</p>

After a night of rest and more searching I have found my problem.

These phones are connecting to a Cisco 3550PoE switch. It appears when the phones start up the Sip.ld they do a reset on the ethernet port. This then causes them to lose power and reboot.

I had to add the following to my switch config:

int range fa0/2 - 24
power inline delay shutdown 20 initial 300

Hope this might help someone else out there.