Polycom 601 bootrom.ld sip.ld problems


#1

Has anyone run into a problem getting a 601 to load a new software image? I picked up a 601 to use for demos and I’m starting to think it’s bad because I can’t get it to load the latest bootroom or sip applications. Here’s a snippet of the log file the phone generates when booting:

0225124637|so |4|00|---------- Initial log entry ----------
0225124637|so |4|00|+++ Note that bootrom log times are in GMT +++
0225124637|wdog |4|00|Initial log entry
0225124637|cfg |4|00|Initial log entry
0225124637|copy |4|00|Initial log entry
0225124637|cdp |4|00|Initial log entry
0225124637|cdp |5|00|CDP is DISABLED.
0225124637|cdp |5|00|802.1Q/VLAN tagging is DISABLED.
0225124637|so |3|00|Platform: Model=SoundPoint IP 601, Assembly=2345-11605-001 Rev=5
0225124637|so |3|00|Platform: Board=2345-11605-001 2
0225124637|so |3|00|Platform: MAC=0004f2026eb9, IP=192.168.251.200, Subnet Mask=255.255.255.0
0225124637|so |3|00|Platform: BootBlock=2.6.0 (11605_001) 30-Apr-05 12:50
0225124637|so |3|00|Application, main: Label=BOOT, Version=3.1.0.0272 14-Jun-05 14:03
0225124637|so |3|00|Application, main: P/N=3150-11069-310
0225124637|app1 |4|00|Initial log entry.
0225124637|app1 |5|00|Preliminary bootROM, beta use only.
0225124637|app1 |4|00|Could not initialize resolver library with server 0.0.0.0 and domain .
0225124802|app1 |3|00|Time has been set from 192.168.251.254(192.168.251.254).
0225124802|app1 |3|00|Bootline: eim(0,0)bootHost:flash e=192.168.251.200:ffffff00 h=192.168.251.198 g=192.168.251.1 u=polycom pw=**** f=0x80 tn=CircaI
0225124802|app1 |3|00|Bootline: P
0225124802|so |3|00|Link status is Net up Speed 100 full Duplex, PC up Speed 100 full Duplex.
0225131927|cfg |4|00|Could not get all 512 bytes of the header.
0225131927|cfg |3|00|New load header information:
0225131927|cfg |3|00|Code length: 0x00141541
0225131927|cfg |3|00|Header check Sum: 0x2014973D
0225131927|cfg |3|00|Code check Sum: 0x0AA5BEE9
0225131927|cfg |3|00|Options: 0x00000003
0225131939|cfg |3|00|New load header information:
0225131939|cfg |3|00|Code length: 0x001414E3
0225131939|cfg |3|00|Header check Sum: 0x201496DF
0225131939|cfg |3|00|Code check Sum: 0x0AA2816C
0225131939|cfg |3|00|Options: 0x00000003
0225131950|cfg |3|00|New load header information:
0225131950|cfg |3|00|Code length: 0x002102B9
0225131950|cfg |3|00|Header check Sum: 0x202184B9
0225131950|cfg |3|00|Code check Sum: 0x115FEA7D
0225131950|cfg |3|00|Options: 0x00000003
0225131950|cfg |3|00|Using compatible image 2.
0225132016|sig |4|00|Initial log entry
0225132016|sig |3|00|hwSigParseRemove: could not find key Sig_3.
0225132016|cfg |5|00|Bad image signature.
0225132016|cfg |5|00|Error updating application.
0225132017|app1 |4|00|Application sip.ld is not compatible with the phone.
0225132022|app1 |6|00|Error application is not present.
0225132022|app1 |6|00|Uploading boot log, time is SAT FEB 25 13:20:23 2006

I’ve formatted the file system, I’ve tried tftp and ftp both from my laptop and my Asterisk server, and I’m about to break out the vodka at 8:51am EST. Any idea what I’m doing wrong here? I’m a Polycom reseller so I’ve got the latest versions of all the files. This is the first Polycom phone I’ve worked on so I’m learning as I go.

Thanks for any help you can give me.

Tom


#2

Download the latest bootrom images also. Try using “SoundPoint IP/SoundStation IP - BootROM 2.6.2” to avoid the upgrade warnings associated with 3.x for now.

The log shows bootrom.ld is not getting loaded prior to sip.ld. Make sure the latest bootrom is in the (t)ftp server’s polycom user home, and that 000000000000.cfg or 0004f2026eb9.cfg paths are good (relative to ~polycom/)

The hint is:
0225124637|app1 |5|00|Preliminary bootROM, beta use only.

where at this point it should be checking the bootrom on the file server.

Andy


#3

I forgot to add the problems I’m having with the bootrom. Currently the phone is running bootrom v3.1.0.0272. I downloaded v3.1.3 and when I put that in the ftp directory the phone downloads just over 400k and says “Error loading bootROM!”. If I remove the bootrom.ld from the ftp directory it starts to boot and then errors out loading sip.ld. If I remove sip.ld from the ftp directory the phone won’t boot at all telling me the application is missing.

I’ve also tried using bootrom 3.1.0 from the Polycom site and that doesn’t load either.

I’m 99% sure the phone is used. I bought it as a demo and the power supply wasn’t packaged up nicely like you’d expect with a new phone, plus it had extension numbers already programmed. I figure it’s screwed up and I’m going to call my distributor on Monday to return it.

Of course, if you know of a way to kick the phone hard enough to load the bootrom I’d be forever grateful. I really wanted to get this demo system going today but it looks like it isn’t happening.

Thanks!

Tom


#4

I don’t think they come with 3.x yet - but you should be able to format the flash and clear configuration, then load 3.1.3 (I’d go with the latest)

Log the ftp transaction on the server side also. Is it timing out? I haven’t tried the 3.x bootroms, but you can’t go back to 2.x once upgraded.

You’ve got to get the bootrom issue sorted out first, I think.


#5

The phone doesn’t log anything when the bootrom download fails. The phone only downloads 417280 bytes before it checks the new bootrom and then displays “Error updating bootROM!”. Then the phone reboots.

Tom


#6

There’s no reason you shouldn’t be able to update the bootrom. In the case of the sip application, I’m pretty sure the phone is not completing the download before it fails also.

Watch your ftp server also - what does it think the reason for the file transfer failure is?

If you can’t: reset to default, reset local config, reset device settings, then format file system; and still not be able to download bootrom or sip, I’d call whoever gave you that phone.

Are you sure your boot/sip images are good?


#7

I am very familar with this problem -

Polycom introduced signed BootROMs and it looks like your phone is wedged. You will need to get a “unsigned” bootROM loaded first, before loading any “signed” bootROMs.

There may be other ways around this, but this is how I’ve worked around these bootROM install issues.

Feel free to contact me for additional help.


#8

Thanks for the offer, Jesster, but I sent it back and ordered a new one. The new one works like a charm. Matter of fact, I think it helped me win a bigger deal yesterday. :smile:


#9

andye hit it on the head with this line

'0225124637|app1 |5|00|Preliminary bootROM, beta use only. ’

With the new signed applications and BootROMs there are actually two types of signatures, a release signature (which is what everything on Polycom’s PRC has, and which is what you should be getting from your resellers), and development signatures, which (as the name implies) is for development and in some cases beta site deployment only.

-mh


#10

I’m with you, MH. Thing first 601 I purchased came that way from the distributor. I knew there was something wrong when I couldn’t register it as my demo gear on Polycom’s website (My company is a certified reseller). I sent the 601 back and ordered another one. Problem solved!