One FXO card out of three still RED


#1

Hi

  1. I found another PC in the office to test Asterisk with 3 101P FXO cards. This motherboard is able to assign an IRQ to each card, while the other host used shared IRQs. According to dmesg and lspci, Linux seems happy. So far, so good.

Problem is, when I plug in an analog line in one of the three cards, zttool doesn’t switch from RED to OK, and calling in doesn’t trigger any RING. The other two cards are fine.

What could be the cause? Not enough voltage to power all three PCI cards (along with a NIC and an AGP cards)? Another cause?

  1. Generally speaking, how can I avoid rebooting every time I make changes to /etc/zaptel.conf, /etc/asterisk/zapata.conf, or /etc/asterisk/extensions.conf?

Thank you
Fred.


#2

You might just have a bad FXO. That should be easy to prove.

Have you tried remove one or both of the working cards to see if the ‘bad’ card can be made to operate?

Have you tried swapping the card to another slot?

Have you tried a new analog line cord?

Mark the ‘bad’ card you’re trying to test with a marker or tape. Setup the box to recognize one FXO card. Then put each card in by themselves, and test operation.

If the other ‘good’ cards work ok, but the ‘bad’ card fails to startup, toss it in the trash…


#3

Thanks. Definitely a bad card :frowning: Guess I’ll have to get another one from eBay.