[Resolved] Sudden failure TDM11B

Consider a single telco line connected to a TDM11B serving a home office. Asterisk had been running fine for 6 months but now all of a sudden incoming calls receive an immediate busy signal and outgoing calls never ring the called party. Internal calls via the FXS port to other internal IP phone extensions still work ok.

If I run “asterisk -rvvvvvv” from the command line and then try an incoming call it shows nothing with the caller getting a busy signal.

Nothing has changed on the Asterisk box. I’ve verified the telco line is working. I’ve tried restarting. It looks like the zap devices are detected/configured ok.

Does this sound like I have a failed FXO module?

Hi Could be

swap the modue to another port and see if it still fails that will prove the module or the card.



I saw this once; the internal power harness had a bad pin. When replaced everything worked again.

I hope it is this simple for you.

Do you get green lights on the back of the card? I did even when the power harness was bad.


I tried moving the FXO module to another slot but it did not help. Same problem as before. I have another FXO module on order so we’ll see if that helps.

The LED’s for FXO/FXS modules both light up green. And using genzaptelconf finds and configures them both. There are no errors everything looks ok from the software/Asterisk side of things. I’ll check the harness.

I wish there was some kind of failure message or diagnostic utility to test it.

A new red FXO module was delivered today. So I popped it in and and fired up Asterisk. And sure enough the system is back functioning normally again. javascript:emoticon(’:P’)