NVFaxDetect make Asterisk die


I am using:

  • Debian Etch4.0r6, x86, VMWare Server 2 (also tried x86_64 on VMWare Server 2)
  • No Zaptel
  • No libpri
  • Spandsp 0.0.4pre16
  • Asterisk (also tried 1.4.17)
  • NVFaxDetect, app_rxfax and app_txfax from SVN AGX Asterisk Addons
  • FreepBX 2.5.1

PSTN connected to Grandstream GXW4104 (configured with T.38 pass-through), and this connected to Asterisk through SIP. I have configured the fax detection on FreePBX in inbound routes with NVFaxDetect. When I make a voice call, the call is redirected to the destination configured in the inbound route (an extension); this is correct. But if the call is a fax, i get this on the CLI:

    -- Executing [7777@from-trunk:1] NoOp("SIP/201-0823d428", "Catch-All DID Match - Found 7777 - You probably want a DID for this.") in new stack
    -- Executing [7777@from-trunk:2] Goto("SIP/201-0823d428", "ext-did|s|1") in new stack
    -- Goto (ext-did,s,1)
    -- Executing [s@ext-did:1] Set("SIP/201-0823d428", "__FROM_DID=s") in new stack
    -- Executing [s@ext-did:2] ExecIf("SIP/201-0823d428", "0 |Set|CALLERID(name)=unknown") in new stack
    -- Executing [s@ext-did:3] Set("SIP/201-0823d428", "FAX_RX_EMAIL=user@domain.com") in new stack
    -- Executing [s@ext-did:4] Answer("SIP/201-0823d428", "") in new stack
    -- Executing [s@ext-did:5] PlayTones("SIP/201-0823d428", "ring") in new stack
    -- Executing [s@ext-did:6] NVFaxDetect("SIP/201-0823d428", "0|t") in new stack
Disconnected from Asterisk server
Executing last minute cleanups
pbx-leovinci:~# Asterisk ended with exit status 127
Asterisk died with code 127.
cat: /var/run/asterisk.pid: No existe el fichero o el directorio
Automatically restarting Asterisk.
mpg123: no process killed

And Asterisk is restarted. Why does this happen? How can I get more info about the crash?

Thanks in advance.