RXFAX problem again

Hello everyone . I have spandsp with rxfax, txfax and nvfaxdetect installed. It seems everything is almost working right. voice calls go where they are supposed to go but faxes aren’t working right. when i send a fax it never answers. This is what I see in the cli.

requested format = ulaw,
requested prefs = (ulaw|alaw|g726|ilbc|gsm|adpcm|lpc10),
actual format = ulaw,
host prefs = (ulaw),
priority = mine
– Executing Macro(“IAX2/voicepulse01-3”, “faxexten”) in new stack
– Executing Answer(“IAX2/voicepulse01-3”, “”) in new stack
– Executing PlayTones(“IAX2/voicepulse01-3”, “ring”) in new stack
– Executing NVFaxDetect(“IAX2/voicepulse01-3”, “4|dt”) in new stack
Nov 28 00:23:53 NOTICE[4011]: app_nv_faxdetect.c:218 nv_detectfax_exec: Redirecting IAX2/voicepulse01-3 to fax extension
– Executing StopPlayTones(“IAX2/voicepulse01-3”, “”) in new stack
– Executing Set(“IAX2/voicepulse01-3”, “FAXFILE=/var/spool/asterisk/fax/_1164691431.0”) in new stack
– Executing Goto(“IAX2/voicepulse01-3”, “fax|s|1”) in new stack
– Goto (fax,s,1)
== Channel ‘IAX2/voicepulse01-3’ jumping out of macro ‘faxexten’
– Executing RxFAX(“IAX2/voicepulse01-3”, “/var/spool/asterisk/fax/_1164691431.0.tif”) in new stack
Segmentation fault
[root@asterisk ~]#

I am faxing over IAX it dies after executing rxfax and gives a segmentation fault.

here is what my dial plan looks like.



include => hello
;exten => s,1,Dial(${ARG1},17) ; wait 3 rings
exten => s,1,Answer
exten => s,2,Playtones(ring) ; play fake ring so caller doesn’t wonder whats going on
exten => s,3,NVFaxDetect(4|dt) ; while playing ring sound, detect faxes for 4 seconds (goes to “fax” extension if detected)
exten => s,4,Goto(s-${DIALSTATUS},1) ; if no fax, branch on dialstatus
exten => s-NOANSWER,1,goto(hello,s,1)
exten => s-NOANSWER,2,Hangup()
exten => s-BUSY,1,goto(hello,s,1})
exten => s-BUSY,2,Hangup()
exten => s-.,1,Goto(s-NOANSWER,1) ; everything else is treated as no answer
; If this is a fax, get it
exten => fax,1,StopPlaytones ; you must do this or it will play ring sounds over your fax
exten => fax,2,Set(FAXFILE=/var/spool/asterisk/fax/${DNID}
exten => fax,3,Goto(fax,s,1)

exten => s,1,rxfax(${FAXFILE}.tif)

I am running 1.2.13 on centos. Any ideas?


First things first.
Does the directory /var/spool/asterisk/fax/ exist ?
and are the permissions correct ?

It seems to be seg faulting.


Yes it does with full permissions


exten => fax,1,StopPlaytones ; you must do this or it will play ring sounds over your fax
exten => fax,2,Set(FAXFILE=/var/spool/asterisk/fax/${CALLERID(num)}${UNIQUEID}.tif)
exten => fax,3,Goto(fax,s,1)

exten => s,1,rxfax(${FAXFILE})


cool i will try that.
I did read last night online someone had the same error message and they said to do this.

enable LZW in libtiff
I searched and searched and cannot figure out how to do this.

Ian I tried what you told me and i still received the Segmentation fault error.
I even removed faxfile and replaced it with
and that still did not work. Any ideas?