Nokia E61i with AsteriskNOW

Hi guys,

Well, before i start this this topic, i searched and tried every post in AsteriskNOW forums about “nokia and asterisk” but didn’t have any luck registering my Nokia E61i with my Asterisk box.

Device: Nokia E61i, Software: 2.0633.65.01

Asterisk config…

[quote][6000]
callwaiting = yes
cid_number = 6000
context = numberplan-custom-1
fullname = Ahmed
hasagent = yes
hasdirectory = no
hasiax = yes
hasmanager = yes
hassip = yes
hasvoicemail = yes
deletevoicemail = no
host = dynamic
mailbox = 6000
secret = 6000
threewaycalling = yes
vmsecret = 6000
registeriax = yes
registersip = yes
autoprov = no
canreinvite = yes
nat = yes
dtmfmode = rfc2833
disallow = all
allow = alaw
signalling = fxo_ks
insecure = very
qualify = yes
notransfer=yes[/quote]

Device Settings…

Tools->Settings->Connection->SIP settings

[quote]Profile name: AsteriskNOW
Service profile: IETF
Default access point:
Public user name: sip:6000@192.168.0.64
Use compression: No
Regristration: Always on
Use security: No [/quote]

[Proxy server]

[quote]Proxy server address: sip:192.168.0.64
Realm: asterisk
User name: 6000
Password: 6000
Allow loose routing: Yes
Transport type: UDP
Port: 5060[/quote]

[Registrar server]

[quote]Registrar serv.addr.: sip:192.168.0.64
Realm: asterisk
User name: 6000
Password: 6000
Transport type: UDP
Port: 5060[/quote]

AsteriskNOW is on a vmware (using xlite on my laptop, i made sure that asterisk was working fine using my access point, and from even outside the network over the internet).

So now that AsteriskNOW is working fine from a softphone and over the internet, i switched to my mobile.

Neither it works from my access point nor over the internet. So I ran wireshark on the host machine of Asterisk, and started reviewing the traffic.

I started xlite, and noticed wut happens, xlite sends a request for registration, then asterisk replies with unauthorized, then it resend the request again, and it becomes authorized.

When i switched to the mobile, i noticed that the sip client request for registration only 1 time, and asterisk responds with unauthorized. I think the issue is in this point.

Am sorry for the long post, and any help would be appreciated.

Thanks in advance,
Ahmed Ossama