Nokia E60, E-Series Phones

Does Asterisk support Nokia E-series SIP phones? Has anymore able to get Nokia E60 to register to Asterisk server?



please find a manual on the URL below:


More importantly, anyone managed to get their hands on an E60 yet?

I got a pair and tried with * but no luck. I tried the link but got no further as without. The phone sends register but with sec-agree in the options. * responds the normal way with trying/unauthorized (digest requested I think) but the phone never responds. I’m no expert but I think the response to the phone should be according to rfc3329.

Shame as this really seems a nice phone and the wifi does not seem to drain the battery too much. btw, The screen/browser is best I’ve seen in this size phone.

Well mine should be arriving am tomorrow, so I guess I’ll get a chance to try it myself. Early reports of beta’s indicated a problem in the area you mentioned.


Hi there,

i got an E60, but it won’t register to asterisk,
So please let us know if someone has it working.


Yes, got it working

Public user name: sip:[PhoneNumber]@:[youre asterisks servers ip] or sip:[PhoneNumber]@[youre_asterisk_servers_hostname]
Use Compression: No
Registration: “Always on” or "When Needed"
Use Security: No

Proxy Server: sip:[youre asterisks servers ip]
Realm: asterisk
User Name: PhoneNumber
Password: PIN
Allow loose routing: Yes
Transport Type: UDP
Port: 5060

Registrar Server: sip:[youre asterisks servers ip]
Realm: asterisk
User Name: PhoneNumber
Password: PIN
Transport Type: UDP
Port: 5060

[note] make sure realm is same as in youre sip.conf case sensitive
default is asterisk

Yes indeed, works wonderfully

Anyone know how I can get the MAC address of the phone?


Anyone know how I can get the MAC address of the phone?
One way of doing it is to ping phone IP, then lookup it in arp cache. Like:

I have managed to make inbound calls to my E60, but can’t make outbound calls to specific extensions because * do not receive extension number.

My sip.conf:

I have simple test configuration in extensions.conf
exten => _X.,1,Verbose(${EXTEN})

When I call any number from the phone, say “71112223344”, E60 adds domain name to it and calls in my case "71112223344@". Thats fine. But asterisk receives just fomain, not the number. The debug output is:
– Executing Verbose(“SIP/e60-d633”, “”) in new stack

What I’m doing wrong?

Mine works as expected. Double check you have the config exactly as shown earlier.


This phone is sweeeeeet. Anyone know where I can buy one ? I am in between the US and Israel.

I suppose the config was for wifi? Has anyone tried using 3G data connection? Also, how’s the VOIP voice quality?


The voice quality on Wifi is better than a mobile call. I’ve tried playing MOH and it’s perfect. Can’t do that well on a mobile call.

Full marks to Nokia for at last producing an excellant business phone. My only issue that I have yet to resolve is if I move out of Wifi range, the phone won’t register with asterisk when I move back into range. It might be a registration problem, or a config somewhere in the WiFi setup.


I got it!

Allow loose routing: Yes
is the key


well I am trying the E60 with asterisk too. I successfully register and use it from an access point in the same LAN of asterisk (no NAT) but when I am at home and try to register to asterisk from outside ( of course using the same parameters as inside apart from the ip address which is NATted to a public ip address ) I can not register.
debugging I get

Sip read:
Route: sip:;lr
Via: SIP/2.0/UDP;branch=z9hG4bKl2s63vr1vsu7p0nsaooukbb
From: sip:edevenaxten@;tag=u5rlccaubdhc65go0kkk
To: sip:edevenaxten@
Contact: sip:edevenaxten@;expires=3600
Call-ID: tx1mcjqSoIfQxMkFin4adQOiI7lpc-
Supported: sec-agree
Max-Forwards: 70
Authorization: Digest realm=“asterisk”,nonce=“7740e7b0”,algorithm=MD5,username=“edevenaxten”,uri=“sip:”,response="2aee69854cb1ba70ed4fbf3704ee66ce"
Content-Length: 0

Transmitting (NAT):
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP;branch=z9hG4bKl2s63vr1vsu7p0nsaooukbb;received=;rport=5060
From: sip:edevenaxten@;tag=u5rlccaubdhc65go0kkk
To: sip:edevenaxten@;tag=as4cb764a3
Call-ID: tx1mcjqSoIfQxMkFin4adQOiI7lpc-
User-Agent: Asterisk PBX
Contact: sip:edevenaxten@
Content-Length: 0

yes. I double checked the password :smile:
I can register only if I comment the “secret” keyword in sip.conf
When I do that E60 works great but just with Alaw and Ulaw codec, if I try G729 I get some hiss/pick/pop that make the phone unusable.

The same happens if I use the UMTS connection ( not enough bandwidth for ALAW , hiss/pop with G729 and the “secret” must be null )

Also another problem is with WLAN encryption. I tried WEP , 802.1x + radius and WPA/PSK. I always manage to ping the phone ( looooose ping ) and the voice was really bad , unusable. All I could do was leave open the AP and use a MAC address filter.

Any help?

I’ve found it and it works !

Q: I need to resolve my Nokia device’s WLAN MAC address, how can I do that?

A: To check the WLAN MAC address type *#62209526# while the phone is in the idle mode.

I have a Nokia E60 and had the same problem that I needed the MAC adres. I send an e-mail to Nokia support and I got the following answer:

Enter *#62209526#

This works but it’s kind of crazy that there is no “system info” icon that can be used to get this kind of info, including MAC, IP number etc. etc…

*#0000# will give you info about the firmware that’s running on the Nokia E60.

I asked them for an easy way to get the IP number that has been given. The answer was really strange. (this a roughly translation from Dutch)

“We haven’t a code available to get the IP number but maybe there is third party software available that can do the trick. We can not disclose any other codes because it could harm your device and that is something you don’t want, do you?”

Nokia came into the network (LAN/WLAN) world without knowing what info people from the network world expect to be available and what info they need to do there tests. WAKE UP NOKIA.

You can’t update your E60 but you need to go to a Nokia serivce point. That’s also kind of strange. I have also a IMate jasjar and I can update and change firmware as many times as I want.

Does anyone know which cell phone carriers have this phone?
This is the E60 SmartPhone you guys are talking about, right?

If the wi-fi at my office is not connected to the same vlan as the asterisk box do I have to put a wireless router on the asterisk box?