No sound at all

Hello to all, im migrating an old asterisk server to a new one, the old one is hp and the newone is a Sunfire v240 UltraSparc III (ubuntu 7 for sparc), i installed the latest * available (1.4.14)
The installation process did not show any error but i cant hear anything at all, in debug mode this error appears

Trying to just play a file (gsm):

  • Executing [22072044@from-safari:3] Playback(“SIP/5060-001d1a30”, “sykes-recording”) in new stack
    – <SIP/5060-001d1a30> Playing ‘sykes-recording’ (language ‘en’)
    [Nov 22 11:52:00] WARNING[5076]: app_playback.c:437 playback_exec: ast_streamfile failed on SIP/5060-001d1a30 for sykes-recording

and ytrying to set a conference using meetme:

<------------->
— (10 headers 0 lines) —
– Executing [conf@from-safari:3] Authenticate(“SIP/5060-001d0fa0”, “1234”) in new stack
– <SIP/5060-001d0fa0> Playing ‘agent-pass’ (language ‘en’)
conference*CLI>
<— SIP read from 200.13.161.68:55790 —>

But i cant hear anything, also this appears in /var/log/messages

Nov 22 11:07:19 conference kernel: [ 2488.114203] ioctl32(asterisk:4284): Unknown cmd fd(15) cmd(80044a2f){t:‘J’;sz:4} arg(f66a28a0) on /dev/zap/timer
Nov 22 11:07:19 conference kernel: [ 2488.114683] ioctl32(asterisk:4284): Unknown cmd fd(15) cmd(80044a02){t:‘J’;sz:4} arg(f66a28a0) on /dev/zap/timer
Nov 22 11:07:23 conference kernel: [ 2492.882641] ioctl32(asterisk:4251): Unknown cmd fd(26) cmd(80044a2f){t:‘J’;sz:4} arg(f6666fc0) on /dev/zap/timer
Nov 22 11:09:25 conference kernel: [ 2614.681475] ioctl32(asterisk:4287): Unknown cmd fd(15) cmd(80044a2f){t:‘J’;sz:4} arg(f66a28a0) on /dev/zap/timer
Nov 22 11:09:25 conference kernel: [ 2614.681932] ioctl32(asterisk:4287): Unknown cmd fd(15) cmd(80044a02){t:‘J’;sz:4} arg(f66a28a0) on /dev/zap/timer
Nov 22 11:10:11 conference kernel: [ 2660.392812] ioctl32(asterisk:3989): Unknown cmd fd(26) cmd(80044a35){t:‘J’;sz:4} arg(f6839124) on /dev/zap/timer
Nov 22 11:10:11 conference kernel: [ 2660.398023] ioctl32(asterisk:4288): Unknown cmd fd(29) cmd(c00c4a0d){t:‘J’;sz:12} arg(f6660a2c) on /dev/zap/pseudo
Nov 22 11:10:11 conference kernel: [ 2660.400117] ioctl32(asterisk:4288): Unknown cmd fd(26) cmd(80044a2f){t:‘J’;sz:4} arg(f6660940) on /dev/zap/timer
Nov 22 11:26:47 conference – MARK –
Nov 22 11:46:47 conference – MARK –

ztdymmy is loaded in kernel:

mmiranda@conference:~$ lsmod
Module Size Used by
zttranscode 10064 0
ipv6 310288 12
ztdummy 4704 0
zaptel 204536 4 zttranscode,ztdummy
crc_ccitt 2560 1 zaptel
ext3 156880 4

what can be wrong?

It does seem to be a ztdummy issue. Try using the latest version of asterisk and zaptel. Also what version of gcc are you using. I recently saw a bug report where gcc was compiling either asterisk or possible zaptel wrong.

i also believe that ztdummy is the culprit here, where did you read the bug? may be is there where i need to post this.

i see zaptel 1.2.21 and 1.4.6, which one is the “correct” one?