No meetme sound


I am having a nightmare with an asterisk setup at the moment. I inherited a voip system that was using asterisk 1.2.4 - about 40 users and 15 meetme lines, all worked fine except the server i was using was not really powerful enough to keep up. So started building a new server (Intel Core 2 Duo) using Ubuntu AMD64, i installed the latest version of asterisk and kept pretty much the standard conf files it came with, adding meetme lines to the extensions.conf file in the form -

; meetme line line123
exten => line123,1,Meetme(4001)


; phone line user123
exten => user123,1,Dial(SIP/user123)

Adding lines to the meetme.conf file in the form -

; line123
conf => 4001

And adding lines to the sip.conf file in the form -

; phone line user123

These are the same as the (working system) using Asterisk 1.2.4.

Point to point phone calls work fine and communication is the same as before, but meetme lines do not work, everything looks fine, clients seem to be able to connect to the meetme lines fine, but the server just will not send out any data to the people on them, so no sound comes through. I did a Wireshark packet dump on it and the clients connect to the meetme lines fine (handshaking succeeds) and the clients send the data to the server correctly, but the server does not send any packets out to the other clients connected to the meetme line.

I have not really got any idea where to start with this (because the handshake works neither the server nor client throw up any errors that i can google for), i will happily post anything that might help somebody help me solve the problem.

Help with this would be very much appreciated, i have a deadline fast looming :frowning:

Just spent a bit of time looking at the old and new servers and it looks like the zaptel ztdummy module is not running as expected, has anybody had any problems running this on a core 2 duo?

I can tell you the ztdummy module works well on a Dell server with an Intel Core 2 Duo 64 bit we setup.


Ok thanks. I checked the kernel options and the processor timing is set to 250Hz, the documentation recommended setting that to 1000Hz, but i checked my (working) server and it’s one is set to 100Hz, is it possible that 100Hz could work but 250 not work?


The processor timing on the server I mentioned is set to 250 Hz, so I don’t think this is the cause of your problem but you can try to change the timing to 1000 Hz anyway and check if it helps.


Try run zttest on the two server and check the output, if ztdummy is working well it should give you an accuracy of more than 99%.


I ran the zttest tool on both, on the working server every second it ticks back with an accuracy of between 99.93 and 99.96, when i do the same thing on the second server it just hangs and not a single tick returns…

Is the ztdummy module loaded?

Yeah, the modules to do with it that are loaded (loaded manually with modprobe) are zaptel, ztdummy, zttranscode, and crc_ccitt.

I initially had a version of zaptel downloaded(version 1.4.9) and this didnt work, so i did an aptitude install of the zaptel package for ubuntu, and it is doing the same thing…

Currently trawling through the archives here to find any similar problems but no luck so far.

What is the output of CLI> zap show status

*CLI> zap show status
Description Alarms IRQ bpviol CRC4

This seems to be the same between both the servers. I also did cat /dev/zap/pseudo, on the working server this seemed to work fine (lots of dots) on the broken server it hung again, but i presume the zttest tool just interprets these dots anyway so to be expected.

I have added and removed both asterisk and zaptel a few times, and zaptel has most recently been compiled after asterisk, i read in a thread here that it could potentially cause a problem, but the zttest tool hanging isnt really an asterisk problem so doubt this will make a difference.

Ok i will presume nobody is sure of the fault, i will be looking into the Ubuntu version i am using to see if that is an issue and will feed back.

On a side note, has anybody looked at creating a new version of what ztdummy does? I would not have thought it would be difficult to create a 1000Hz timer, does anybody know the interface between asterisk and the zaptel module with regards to the timer?


I dont know if anybody has had any luck with this, i have build it on a different computer (still a core 2 duo) and it does exactly the same thing…


I’m not sure that this post is active.

Does your application playback works ? in doubt can you make a test?
I have the same pb as deacribed in this post with a 2.6.21 kernel. The timer is 1000 hz.

Unfortunately i never found a solution to this problem, i ended up using different hardware (Athlon Dual 2200) and it worked without any problems.

There is a replacement kernel module for the Real Time Clock available - which may help you, let me know if you manage to solve this.


Great thanks

I will test it tomorow.