No Playback() with ztDummy

I’ve got a Dell with Intel Xeon and no Zaptel hardware installed. However, as it needs to do IAX trunking and MeetMe conferences I need timing enabled using ztDummy.

However, when enabling ztDummy Playback() and Background() both fail to play.

If I place NoOp(${PLAYBACKSTATUS}) after the Playback() call it never reaches it. It hangs on the playback then kills the call after a certain time.

As soon as I rmmod ztdummy and zaptel it starts working again.

I’ve found the following mail list thread which seems to be very similar but no solution came to pass: … 47641.html

I’d be very grateful for anyones input.

what does lsmod say ?

The only times i have seen this is when a zaptel card is installed but ztdummy is loaded.

did you install zaptel and asterisk ? to enable ztdummy


lsmod returns:

claymore:/etc/asterisk# lsmod | grep z
Module                  Size  Used by
ztdummy                 5160  0
zaptel                186180  1 ztdummy
crc_ccitt               2240  1 zaptel
rtc                    12372  1 ztdummy

There’s no Zaptel hardware installed and no other zap drivers loaded other than ztdummy.

I’ve tried to run “ztcfg -vvv” but it simply hangs with no output. When running zttool it says the ztdummy interface has an alarm state of “UNCONFIGURED” but after doing some digging this is normal.

Any ideas - you sound like you may have a solution. :smile:

I would go for a recompile.

ie for zaptel
make install
make config

and for asterisk
make install

the restart the server.


Already tried that.

Completely removed everything Asterisk-related. Got the latest stable release and did a re-compile. No luck.

Even done apt-get upgrade of system. Still no luck.

Hi What does dmesg say ?

Also what do you get when at the asterisk cli prompt for zap show channels ?


I too have exactly the same problem.
dmesg says;
rtc: lost some interrupts at 1024Hz.
rtc: lost some interrupts at 1024Hz.
rtc: lost some interrupts at 1024Hz.
rtc: lost some interrupts at 1024Hz.
rtc: lost some interrupts at 1024Hz.

There also is some setting you can change in /proc if you get these kinds of messages, this had no effect.

The kernel I’m using as base is:
2.6.18-6-686-bigmem #1 SMP Sun Feb 10 22:21:07 UTC 2008 i686 GNU/Linux (Debian Etch)

I do fear this problem is a bug in Asterisk or Zaptel.
Furthermore, I’m using Asterisk for these tests.

After I’d remove the zaptel related modules from the kernel, everything returned to normal. However, when I tried this again, zaptel wouldn’t respond, and I hate to force it’s removal. Which caused a kernel OOPS, together with non-working audio and a new kernel OOPS every time a call came in.

Furthermore, I am unsure if this is a issue with playback, as there is simply no RTP flow present!

I also get the following on dmesg:

The output of zap show channels is:

claymore*CLI> zap show channels Chan Extension Context Language MOH Interpret pseudo default default

Any ideas?

What’s the /proc setting you can change?

That sounds like an issue I had… on a dell server playback would just not play anything and hang/pause there. And I was getting the same in dmesg as you.

I found I had to recompile the kernel with HPET_EMULATE_RTC enabled. I was using a 64bit ubuntu setup and by default that is off. If I was using the 32bit it would have been fine as that is enabled.

Here’s another forum thread with some other things to try too, the 2nd post down has the older version of the wiki on zap and kernel 2.6: … c7002b7ec2


This is the proc setting I was talking about. The source of this is: … …-344053/

My next attempt will be the following, I found on the Asterisk-users mailinglist:
(written on 13 Mar 2007)

However, I am using Asterisk 1.2, together with an older version of Zaptel.
So I’ll need to figure out first if this is something that is actually possible in the latest 1.2 version (1.2.25) of zaptel.

I’ve taken a look at the kernel config file used for the current kernel.
I can’t seem to find a single reference to HPET_EMULATE_RTC.
This is what I can find:

Furthermore, if I were to look for the RTC itself in the config, this is what would pop up:

edit reason: updated Zaptel version to match the version I’m using.

Okay… I fixed it!
Still I’m getting a delay in a meetme room when I’m sitting next to someone else trying, but I’m blaming that on the default meetme operations.

Right, what I did was:

  1. Recompile the default Debian kernel with a timer of 1000Hz instead of 256Hz. (Needed for Zaptels timing).
  2. Commented out the defines for the RTC from ztdummy.c
  3. Recompiled zaptel & installed it (not the init scripts though).
  4. Recompiled asterisk and installed it.
  5. Ran modprobe ztdummy
  6. Activated a meetme conference.

Will something like this also work for you?