No Sound on Playback/Background


I’m having a wierd problem

I had this setup

GSMBOX [FXS]---ANALOG LINE---[FXO]+------------|
                                  |  ASTERISK  +[SOME SIP DEVS]
  [BRI] --- ISDN LINE --- [ZAPHFC]+------------|

In this configuration all worked well until by a reboot caused by a power loss the fxo card died… So i took it out of the box and disabled the configuration (commented it for the most of it). A few day’s ago I received the replacement so I placed the system back in the original configuration.

It appears that the card is recognized because asterisk starts fine, no problem what so ever… i can place calls and receive calls on the zaphfc intderface but I cant do anything with the fxo interface. BUT on either interface (ZAPHFC/SIP/…) from the moment i play some sound using Playback or Background the call “hangs” until the caller hangs up… that it continues.

I’ve seen that zapdummy can have this problem (some post here and also on the userlist, but i’m not sure if its related)

Can anybody help?

Did you load Ztdummy ? If you are using a card for timing it should be disabled. When you run ztcfg -vvvv what do you get ? Also if you run
lsmod | grep zaptel what do you get ?


this is what i get when i run ztcfg -vvvv: (there is nothing i won’t expect)

pabx ~ # ztcfg -vvvv

Zaptel Configuration

SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)

Channel map:

Channel 01: FXS Kewlstart (Default) (Slaves: 01)
Channel 02: Clear channel (Default) (Slaves: 02)
Channel 03: Clear channel (Default) (Slaves: 03)
Channel 04: D-channel (Default) (Slaves: 04)

4 channels configured.

pabx ~ #

this is what I get with lsmod | grep zaptel:

pabx ~ # lsmod | grep zaptel
zaptel                172964  12 zaphfc,wcfxo
pabx ~ #

zaphfc is used 3 times, wcfxo 0 times (this last might be a problem, allthough when the module loads is get:

Nov 16 09:49:38 pabx PCI: setting IRQ 10 as level-triggered
Nov 16 09:49:38 pabx PCI: Found IRQ 10 for device 0000:00:09.0
Nov 16 09:49:38 pabx wcfxo: DAA mode is 'FCC'
Nov 16 09:49:38 pabx Found a Wildcard FXO: Wildcard X100P

Thanks for any help or intel :wink:

I never used X100P so I can not comment for certain on it but maybe this card just has an issue. Try pulling out the card, build zaptel with ztdummy and see what happens. Please post your result here.