X-Lite Remote Won't Register

I’m running * on FreeBSD-6.1 behind a NATD/Gateway that’s connected to the Internet. I can make and receive calls from FWD and I have a connection with splitinfinity that allow VOIP calls to the PSTN. All that is working fine.

Tonight I installed X-Lite on my office laptop and tried to connect to my * server which is at my residence. Nothing I tried worked. I keep getting the 408 Timeout error.

My NATD/Gateway box is another FreeBSD box and I don’t find any evidence of it dropping packets. It’s setup to forward like so:

redirect_port udp 5060
redirect_port udp 5082
redirect_port udp 4569
redirect_port udp 2727
redirect_port udp 9999-20001

I opened the firewall wide up but still nothing. If memory serves me right I made a call using an older version of X-Lite a few weeks ago from a hotel in Milwuakee on this system. But I can’t seem to put my finger on why this setup won’t work.

The the tech with X-Lite seems to think it’s my * server and he’s probably right because he couldn’t connect either. Any advice or pointers will be appreciated.

I had the same problem. Do you have SIP & RTP port forwarding on your router/firewall? I would forward SIP ports 5060 - 5082 and RTP ports 8000 - 20000 to your * server IP address. Then edit rtp.conf - from rtpstart=10000 to rtpstart=8000 since 8000 is the default RTP port on x-lite phones. Also enter the same externip=xxx.xxx.xxx.xxx and localnet=xxx.xxx.xxx.xxx/xxx.xxx.xxx.xxx info from your sip.conf general settings into sip_nat.conf. Then in sip.conf under the remote extension account add nat=yes, canreinvite=no . This should get it working flawlessly, it did it for me after much research and troubleshooting.

I took your advice and made the changes to my * config files, and have both upd and tcp ports forwarded but it’s still not working.

Can you tell me about the sip_nat.conf file. I assume I was to make a new entry for this phone like this:


I also made the suggested changes to sip.conf and then did a reload from the command line. Still I’m getting the same 408 error message.

My firewall does not show any sign of packets being dropped. I can access my entire network at home from anywhere on the Internet, including ssh to the * server to make the changes. So I’m getting through but I can’t track where the packets are either being blocked or if my * setup is still missing something. I’ve never used tcpdump…guess it’s time to start learning how to trace packets…boring…!

Thanks for the advice. If you think of anything else, please pass it on.

no, that only belongs in the [general] section of sip.conf. Asterisk uses it to determine if a host/peer/user is local and substitutes externip if it’s not.

sip_nat.conf is a function of the setup of AMP or FreePBX, and it’s used as an include to sip.conf.

It almost works. In the X-Lite Sip Account setting under the topology tab I manually specified the port range of 5060 to 5070. Suddenly I was in and able to make calls…but I can’t here anything on this end. The same may be true back at my * server but it’s 30 miles away at my residence and I won’t know until I get there and can check if the voicemail I left was recorded.

I was also able to make a call using my PSTN provider and that call came into my office phone. I answered the call and could once again could only hear audio through my office phone. The ringing was clear on the speakers but no voice could be heard once the call was connected. It was fast, almost instaneous they way my voice traveled into the PC’s mic and then out to the world, through my company’s switchboard (also VOIP) and then to my desk phone. Only a small amount of static was detected.

So if anyone has a clue as to why I can’t hear audio on this end, please feel free to comment.

It was my firewall rules. I had a rule to open port 5060…but it also needed 5062 so as in my port forwards I opened up 5060 - 5082. It’s working now. A little pop in the audio now and then when I’m talking but the moh is crisp and clear as a bell.

Thanks gang.


Its good to know that things are actually working out for us all.

sip_nat.conf settings should look like this:

externip=your WAN or external IP address or domain name
localnet=your * server IP address/your * server subnet mask

It should look like this:


…that’s all it should contain and nothing more.

i don’t know how many times this is going to have to be said. sip_nat.conf is “included” by sip.conf in your setup. not everyone has a sip_nat.conf, 'cos not everyone is running AAH/FreePBX/AMP/TrixBox.

those directives belong in the [general] section of sip.conf


Thanks once again for your seasoned advice. I was so desperate to make the thing work that I did not even notice the sip_nat.conf file I thought I was editing was actually sip_notify.conf. Thanks to the TAB complete function of my server’s command line I just thought I was working with sip_nat.conf.

The new firewall rules have everything working hunky-dory.

BTW - I notice several posts and people in the * IRC that complain of crashes. I use FreeBSD-6.1, not Linux, and my server’s performance is rock solid. It’s an old Dell Optiplex with a P220 processor with 64MB RAM. The only crashes I’ve had have been caused by a short circuit between my chair and the keyboard. Right now my speaker phone is quietly playing the smoothest Jazz moh for me while I work. And the * box get’s it’s music from yet another FreeBSD server on my LAN that stores all my mp3’s. I tell you this * thingy is going to rock the telecommunications world to it’s knees.