Mitel phone compatability

I have see a few topics relating to Mitel handsets. I was wondering if any one had experience migrating/server changover from a complete Mitel system and just replacing the server with an Asterisk based solution but keeping all the Mitel handsets. If so did it work and what problems arose? (if any)

Appreciate any feedback.

I am trying this at the moment on a dev platform, 5330’s -> * server, but due to mitel cracking down on F/W distribution to non partners/ resellers i am having some seriously late nights trying to work around this, plus i am a bit of a newbie with this stuff. If i get hold of the correct SIP F/W for the 5330’s i am quite sure i can get it working and if/ when i do i will let you know.

Thanks Mark,

I thought someone would say something like that.

The system in concern is a Mitel 2006 model, which supports a maximum of 700 clients (SIP), and the system is currently running up to 650 mark. As far as I am aware this Proprietary system has little scope for expansion and is not feature rich.

But listen to this: The current owners started out with this system as a trial, they then decided to keep going with it as it seem to do what they wanted, the average cost of each device with licence and mailbox licence has set back around £200 per client.

I don’t need to tell you that’s around £130,000 of kit, or over there in the states 205,952.50 USD. That may turn out to be useless unless they again upgrade to a new Mitel system with upgraded licences so addtional costs after the purchase of the server. ouch. not bad for a not for profit organisation.

Let me know how you get on.


I am not expert just a beginner, I found this on another forum it may be some use or may not be, I believe its for v.6.
If your familer with editing the sip.conf file then this example I found on another forum.

Sip.conf example:


Sorry if its not use.

I am certainly no expert either!, and i must have read almost all threads relating to Mitel IP Phones and * over the last few days lol.

I am reasonably confident that my * config (as per your sip.conf post) is ok but i am still at the stage of getting the 5330 phones loaded with the correct F/W and being able to actually access the fabled web configuration portal as opposed to this TFTP upload html splash screen i get.

I am doing this build for a customer of mine, they are a charity and have been donated a bunch of 5330 phones with SIP f/w on as i can get them to boot into SIP mode but i suspect there is a problem with the f/w as i cannot access the web portal configuration page and i do not suspect that i will get my hands on this f/w easily.
At least that is what i think is the problem with the inability to access the web portal.

also due to the fact that the phones were donated naturally no s/w, .cfg templates, .bin files etc… came with them and it seems to be a bit of a struggle to find out exactly what .cfg .bin files are required for the phones, i have generated a few test .cfg files and they seem to work but still not registering the phone, i really need access to the web portal!!

Just as a check. Please don’t think I’m trying to say you have not done this already, but have you ran a wireshark/network analyser on the connection to see whats going on when you try to access it. As well as this can you ping the phone from the server?

Dont worry about giving advise!! i need all that i can get, the issue is that i can access a web page when i browse to the phone and with the tftp log files i can see it is picking up the test .cfg’s i created so as far as network convergence goes i can see that it is on the network and the server can ping the phone and vice versa.

I simply dont know what i need to do to get access to the web config tool, i can only assume its a f/w issue, or a lack of .cfg files.

the page i get when i browse to the phone is attached.

okay, what *.bin files have you tried?

have you tried the sip5235dpltone_GB.bin (for Example)??

i dont have any .bin files for the 5330, or am i being an idiot?!? i have a set for 52xx series, did not think i could use them.

that is the basis of my predicament! i cannot get hold of these blinking files lol.

Ok, so i found a good document online with the correct structure and syntax for the .cfg files, got the 5330 registered with * server and can make/ rx calls internally so far. Looks like i need the correct files for this phone still for the web access app and could really do with getting hold of the f/w.

Can you post a link to that page, please?
I can’t find any documentation at all… Many thanks in advance.