Missing SIP entries in Registry [Solved}

I have 3 separate asterisk boxes all running version 1.4.44. Two of these boxes are production and the other for development. All 3 boxes have separate SIP provider accounts and can place/receive calls, however, when I enter ‘sip show registry’ in the CLI, I see the following empty list:

sip show registry
Host Username Refresh State Reg.Time

I also host a FreePBX box running version 1.8 on the same network as the other 3, and on it I can see the SIP account registry, so I don’t think it’s a firewall issue

I’ve been using asterisk now for almost seven years and have not seen this behavior. I find it interesting that all 3 of these boxes have the same result, ability to make calls but not show in the registry.

Any ideas of what I should look at as a possible cause?

I’ve figured out my problem. For one account, I was missing the ‘register=yes’ line in sip.conf. The other account was configured through the Carriers’ settings in the Vicidial admin screen. Moving the settings directly to sip.conf has allowed that account to register as well.