Make menuselect with no graphical interface?

I am using Asterisk 17.0.0 with pjsip on centos 7.6. When I run ‘make menuselect’, I see all the options, but there is no graphical menu showing (only the options, and I can select them by tabbing). It is like ncurses is not installed, however, I verified ncurses is install and I even re-installed it. Any ideas?

Thank you

Could your terminal type be set wrong?

What does the output of echo $TERM give you?

It is set to xterm. I have Asterisk on many other servers that are set to xterm and ‘make menuselect’ has no issues on those servers.

-Thank you

There might be additional dependencies on newt and newt-devel, but I’ve used the simple ncurses interface myself in the past.

In you case it could make sense to visit the contrib/script directory and run the script install_prereq. It may also be necessary to rerun configure with suitable options (like --with-jansson-bundled --with-pjproject-bundled, which is what I usually use on CentOS).

Thank you EkFudrek,

I tried everything you mentioned, but I till don’t see the graphical interface. I don’t see any obvious errors. I’m really not sure what else to try other than trying to figure out if an error is being written somewhere (I’ve looked in all the standard logs).

Does configure complain about something? Can you capture the output of “make menuselect”?

Are there any other programs with display errors (like vim, or simple tests with dialog)?

I was missing newt-devel. I installed this and now I have expected user interface.
Note: On Centos 7.6, I had to install newt-devel from rpm (which requires slang-devel), yum install did not work!

Thank you all for all your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.