Installing Asterisk with make menuselect

I’m trying to run ‘make menuselect’ on asterisk but keep getting an error message stating that ncurses and/or newt are not installed, but they are.

This is just a lab vmware environment and I can’t figure out how to install vmtools without installing x, so I can’t copy/paste output here.

I installed zaptel for ztdummy (make clean, make, make install, and make config) with no errors. It may be important to note that I did get an error when executing a ‘make menuselect’ on zaptel indicating that I didn’t have ncurses installed. A quick ‘rpm -q ncurses ncurses-devel’ outputs: ncurses-5.4-15.el4 and ncurses-devel-5.4-15.e14.

Then I cd’d to the asterisk dir and executed make clean and .configure with no errors, but a ‘make menuselect’ ends with “No menuselect user interface found. Install ncurses, newt or GTK libraries to build one and re-rerun ‘make menuselect’.”

I’ve confirmed via ‘rpm -q ncurses ncurses-devel newt newt-devel’ that I have the following installed:

From locate, it looks like the above 4 are installed under /usr/lib so I added that to my path just in case, but I’m still getting the same error when trying to execute ‘make menuselect’ under the asterisk dir.

Any ideas?


I have the same problem, with asterisk- on Fedora 8 in Amazon EC2. I eventually just skipped “make menuselect” completely, but that’s not a good solution.

Same problem width Asterisk- on Centos 5.3 :
.configure with no errors, but a ‘make menuselect’ ends with “No menuselect user interface found. Install ncurses, newt or GTK libraries to build one and re-rerun ‘make menuselect’.”

ncurse, enwt and GTK lib are installed …

yum install kernel-devel
yum update kernel

yum install bison bison-devel ncurses ncurses-devel zlib zlib-devel openssl openssl-devel gnutls-devel gcc gcc-c++ newt newt-devel libtermcap-devel

Kernel part is important for zaptel/dahdi.
All this did perfect job for me to install fresh Asterisk on fresh CentOS system - using menuselect also.

I’v installded all that. Make menuselect still don’t work.


Last idea (I have) - when you start ./configure - check very carefully:
checking … yes
checking … no
where you have no and if it could be a problem.

If make menuselect is not working and the error is shown as
"No menuselect user interface found. Install ncurses" then use the command

apt-get install ncurses-devel

even if this does not works and error is shown as “Couldn’t find package ncurses-devel” Then use the command

apt-get install ncurses

Hope this finds solution to your problem. :smiley:
Even if this does not works then This may mean that the package is missing, has been obsoleted, or is only available from another source and the error is displayed as “Package ncurses has no installation candidate”.Then u need to look for the package in your application.

Try deleting and re-extracting the tarball before running ./configure and make menuselect again.’

I had run make menuselect before ncurses-devel was installed, installed the package and it still failed until deleting the source and starting over.

For others coming across this thread from Google…
Deleting the directory and untarring asterisk 1.6.1.tar.gz corrected my make menuselect problem as well.

make distclean

make menuselect

worked for me… instead of deleting and re-extracting the tarball.