Make b410p problem

This is the error I get when i do a make b410p

root@ss-ubuntu:/usr/src/zaptel-1.4.0# make b410p
-p: not found
chkconfig: not found
grep: /include/linux/autoconf.h: No such file or directory
[ -f ] || wget … 10p.tar.gz
–14:15:47-- … 10p.tar.gz
=> `misdn-b410p.tar.gz.2’
Connecting to||:21… connected.
Logging in as anonymous … Logged in!
==> SYST … done. ==> PWD … done.
==> TYPE I … done. ==> CWD /pub/zaptel/b410p … done.
==> PASV … done. ==> RETR misdn-b410p.tar.gz … done.
Length: 572,153 (559K) (unauthoritative)

100%[====================================>] 572,153 231.72K/s

14:15:51 (231.08 KB/s) - `misdn-b410p.tar.gz.2’ saved [572153]

tar -zxf misdn-b410p.tar.gz
make -C misdn install
make[1]: Entering directory `/usr/src/zaptel-1.4.0/misdn’
!!You should remove the following files:


In order to upgrade to the mqueue branch

-ne I can do that for you, just type: make force

make[1]: *** [test_old_misdn] Error 1
make[1]: Leaving directory `/usr/src/zaptel-1.4.0/misdn’
make: *** [b410p] Error 2

My linux distro is Ubuntu 6.10 server.

any help would be appreciated.

you’re the 3rd “daniel” in a week to be asking about mISDN on a b410p :smiley:

don’t like the “chkconfig not found”, nor the lack of autoconf. can you download and install the appropriate packages for these ?

the error you have suggests removing some files, or using “make force”. does that enable it to compile properly ?

i’ve also heard that Digium say the mISDN package they use is faulty. but you need to use it as the mISDN CVS doesn’t appear to support the Digium card. a combination of the both works though.

There isn`t chkconfig in Debian/Ubuntu…

I did remove those files and also i used the “make force”, but unfortunately it didn`t resolve the problem…

Any ideas?

can you get the kernel headers for your distro ? and edit the makefile so that it uses whatever app your distro uses to add a “service”

have you downloaded the mISDN CVS and installed ?

Yes I’ve downloaded mISDN CVS but same problem occurs. I’ll try to edit the makefile and see if it works.

Thank you for your time and help.

i’d offer to SSH in, but i’m not at all familiar with Ubuntu :unamused: