B410P installation problem

Greetings everyone,

Recently i bought a B410P BRI card and i’m trying to install it in Fedora Core 9 (kernel: 2.6.25-14). I inserted the card in the PCI slot and it is detected (lspci). I tried to install the zaptel (1.4.11). I execute the following commands (as shown in user manual):

make clean
make install
make b410p

When ‘make b410p’ is executed i get the following error (last part):

cp /usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN/Makefile.v2.6 /usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN/Makefile
export MINCLUDES=/usr/src/zaptel-1.4.11/mISDN-1_1_7_2/include ; export MISDNVERSION=1_1_7_2; make -C /lib/modules/2.6.25-14.fc9.i686/build SUBDIRS=/usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN modules CONFIG_MISDN_DRV=mCONFIG_MISDN_DSP=m  CONFIG_MISDN_HFCMULTI=m  CONFIG_MISDN_HFCPCI=m CONFIG_MISDN_HFCUSB=m CONFIG_MISDN_XHFC=m CONFIG_MISDN_HFCMINI=m CONFIG_MISDN_W6692=m CONFIG_MISDN_SPEEDFAX=m CONFIG_MISDN_AVM_FRITZ=m CONFIG_MISDN_NETJET=m CONFIG_MISDN_DEBUGTOOL=m
make[2]: Entering directory `/usr/src/kernels/2.6.25-14.fc9.i686'
scripts/Makefile.build:46: *** CFLAGS was changed in "/usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN/Makefile". Fix it to use EXTRA_CFLAGS.  Stop.
make[2]: *** [_module_/usr/src/zaptel-1.4.11/mISDN-1_1_7_2/drivers/isdn/hardware/mISDN] Error 2
make[2]: Leaving directory `/usr/src/kernels/2.6.25-14.fc9.i686'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/zaptel-1.4.11/mISDN-1_1_7_2'
make: *** [b410p] Error 2

I tried to search all over the net but no luck. Does anyone came across such an error before.

I’ll really appreciate any help
Thanks in advance

Sorry for the duplication, there was some connection problem with the site.


this may help
asteriskguru.com/tutorials/d … guide.html

Thanks a lot riddlebox,

Actually i followed those steps but i’m stuck at make b410p.
I think my problem might be the kernel version. I have 2.6.25 while in the guide you suggested it says it should be less then 2.6.18. I’ll find a way to downgrade to this kernel and try again.

Thanks a lot


I managed to install the zaptel driver successfully. I believe the problem was with the kernel version. Now i installed Fedora core 5 with kernel 2.6.15-1.2054. I installed zaptel 1.4.11 and asterisk (clean install). The installation went fine. However, the lights are red (not green). The card is found and the driver is loaded. I set up /etc/misdn-init.conf and /etc/asterisk/misdn.conf as shown in the guide. Also the command misdn is not available in the astersik CLI.

The strange thing is that firstly i installed zaptel 1.2.26 and asterisk and after completing all the steps the light was on. (Just want to mention that i use only one of the ports). I didn’t do any other configuration to test the calls, as i thought is better to install the latest versions of zaptel and asterisk.

The isdn line works fine as i tried to make some calls using isdn phone. So basically the problem is with my configuration.

This is my misdn-init.conf:


Another question: Since i’m using only one port of the card (i got only 2 isdn lines), should i disable the other three ports (is there any way to disable them)?

Any help is greatly appreciated!
Thanks in advance

I have been using two systems with b410p’s , which only make use of 2 ports. I have the card setup in ptmp mode an te ports. In OZ Telstra do something with the L1 or L2 i think, and turn sync off after 15 minutes odd to save power i believe, so the lights only go green while calls are in progress, and go back to all flashing red if nothing is going on. Be careful on kernels when using misdn. I use Centos 5.1 with 2.6.18 and all is good. I think there might be issues with kernels prior to that.

If it’s worth anything I have always compiled mISDN and mISDN-user from misdn.org. Haven’t had any dramas. I only compile zaptel for ztdummy use in timing, seeing as the b410p is not a zaptel card.