[SOLVED]b410p / mISDN / chan_misdn = installation impossibe

Hi all,

Centos / Debian sarge with kernel 2.6.15 / Ubuntu 6.10… I’ve never had succesful complete installation of my 2 new b410p.

I’ve follewed many process found from Digium / Asteriskguru / Beronet… without any succes.

Does somebody have experience with this card ?
If yes : With wich Linux edition ? If you have an how to provide … I’ll be the happiest guy in this voip’s wolrd !

I’ve allready spent 3 days (and night…) and I’ve no more idea how to success !

Thank you in advance for your repply.


I have managed to install on Centos 4.3 (with updated kernel 2.6.16) and Asterisk 1.2.12

Install the new kernel
in zaptel source directory (zaptel- do: make b410p
(or just download misdn-b410p.tar.gz and mISDNuser.tar.gz and compile both)
/usr/sbin/misdn-init {start|stop|restart|config|scan|help}
then modify /etc/asterisk/misdn.conf


Module Size Used by
mISDN_dsp 198156 0
hfcmulti 70632 0
mISDN_capi 95436 0
l3udss1 43928 0
mISDN_l2 42768 0
mISDN_l1 15352 0
mISDN_core 77952 6 mISDN_dsp,hfcmulti,mISDN_capi,l3udss1,mISDN_l2,mISDN_l1
vfat 16768 0
fat 52892 1 vfat
capi 22208 0
capifs 9864 2 capi
kernelcapi 49536 2 mISDN_capi,capi

I might have forgot something, so see how far you get, :smile:

Thank your interrest !
Did you compile your kernel from source from kernel.org ?

I’ve forgoted to list SME 7 E-SMITH EDITION (based on Centos but kernel lower than 2.6.15) in my test list.

I’m downloading centos server 4.4… I’ll keep you & the forum shortly.
Rgs, FB.

For yusuf…

same pb as yoursw…

Did you get any solution ?

FYI : Compilation succed with centos 4.4 with kernel updated to


floturc, yes that was my problem, but with 1.4 beta3. Now that 1.4.0 has been released, I have got the drivers to compile.

Did you fix something to compile chan_misdn in * 1.4 ?
I’ve exactly the same symptom that yours in bebta3…

I’ve tried to modify manually the menuselect (removing depency). So chan_misdn in make menuconfig apper selecte but make doesn’t compile and return an error…


Hi all,

Dihium : Could please be a bit more expplit to setup this card !!

What you will have to do :
1/ Get an os whith kernel >2.6.15 and <2.6.18 (Centos for axample)
2/ Make b410p from zaptel
3/ Get mISDNuser from misdn.org/downloads/mISDNuser.tar.gz
untar & make & make install (to resolve menu dependancy from Asterisk : “suppserv”)
4) ./configure from asterisk src
5/ NOW in make menuconfig : chan_misdn soukd appear as selectable
6/ make & make install as usual

Enjoy, FB.