Issue with Paging


I am working on OpenWRT. I am building OpenWRT image with the asterisk 13.

I am trying to use Paging functionality of asterisk with Page(). I already added the Page() in extensions.conf.

However, I am getting following error:

pbx.c:2814 pbx_extension_helper: No application ‘Page’ for extension (incoming-cont, 9999, 2)
== Spawn extension (incoming-cont, 9999, 2) exited non-zero on ‘PJSIP/9858-00000000’

what am I doing wrong?


exten => 9999,1,NoOp(context-dahdi)
same => n,Page(${PJSIP_DIAL_CONTACTS(9999)},30)

I also tried,

exten => 9999,1,NoOp(context-dahdi)
same => n,Page(${PJSIP/9999),30)

If I use Dial() instead of Page(), everything works fine.
I also double checked makefile with"". Do I need to install any package or any line in the makefile to add Page() function?

The Page application is part of Asterisk and should be built by default. It’s likely something in the openwrt area that is stopping it from being built or installed.

try a ‘module show like app_’ at the console.

Do you see in the list returned?

Thanks for replying everyone.

I am seeing following as the output. There is no           Alarm Receiver for Asterisk              0          Running          extended             Check channel availability               0          Running          extended                 Listen to the audio of an active channel 0          Running              core              Conference Bridge Application            0          Running              core                    Dialing Application                      0          Running              core                    Simple Echo Application                  0          Running              core                    Executes dialplan applications           0          Running              core                   Extension Macros                         0          Running              core               Originate call                           0          Running              core                Sound File Playback Application          0          Running              core               Playtones Application                    0          Running              core                    Read Variable Application                0          Running              core               Read and evaluate extension validity     0          Running              core                  Trivial Record Application               0          Running              core             Say time                                 0          Running              core                Send DTMF digits Application             0          Running              core                   Dialplan subroutines (Gosub, Return, etc 0          Running              core                  Generic System() application             0          Running              core              Playback with Talk Detection             0          Running          extended                 Send verbose output                      0          Running              core               Comedian Mail (Voicemail System)         0          Running              core               Wait until specified time                0          Running              core                   While Loops and Conditional Execution    0          Running              core

Try ‘module load’ and see if you can load it, You may need to add it to your modules.conf if you are not using autoload=yes

I tried it, but got the following error:

root-612c*CLI> module load
Unable to load module
Command ‘module load’ failed.
[Oct 5 17:33:24] WARNING[11074]: loader.c:556 load_dynamic_module: Error loading module ‘’: File not found
[Oct 5 17:33:24] WARNING[11074]: loader.c:1086 load_resource: Module ‘’ could not be loaded.

OK, Did you select it with menuselect when you compiled Asterisk?

I am building customize openwrt and building asterisk with Makfile in it.

But I did check in the asterisk directory and did make menuselect to see the selected options and it shows following.

So app_page is selected.

Do I need any dependencies for it?

OK, when you do your make does it get build in the apps directory?

Page needs confbridge, it shows that in your screenshot.

confbridge() is working fine. I am using it, but paging() is giving me the mentioned error.

It does not appear as though is actually being installed, this still seems to point to your environment - you need to isolate things further.

1 Like