Installing H323 in asterisk-1.4.0

I installed the PWLIB and the OPENH323 libraries, changed path to the OPENH323 in the asterisk-1.4.0/channels/h323/Makefile, isuued make opt and got libchanh323.a. Then I returned to the top directory and issued make install, but did not appeared in the /usr/lib/asterisk/modules.
What should I do with this libchanh323.a?


I had a lot of problemessssssss too with h323 during the compilation of asterisk …
But don’t worry, since I haven’t find how to make it, I didn’t installed it and I don’t use it with my asterisk : all of my phones use sip protocol.


That’s cool, but that’s not it. I really need H323 to run with the Asterisk, and I have problems with OOH323 while calling to the SIP.
Any other ideas?

Have you try to compile openh323 (, it also provides h323.

I did. I tried to compile asterisk-oh323-0.7.3 and have got a lot of error messages by compiler, even not from linker :frowning:

Those who used H323 with * - please, HELP :cry:

What’s up pseudoz, I shared your pain a couple of weeks ago but I got mine working so, let try to help. I will tell you what I did and try to help you anyway I can. First if you need to re-install Asterisk here is site that will help you clean it off the computer so you can start over. fourth paragraph down “removing asterisk”

You have to install flex, this is an additional package for PWlib. flex-2.5.4a, then pwlib-v1_10_0 and openh323-v1_18_0 this is the combination that works. I installed in root. If you need to re-configure them is no big deal look up the readme file in asterisk/channels/h323 but they need to be installed. Here’s what I did. Run the following.

• Flex
./configure --prefix=/usr
make install

• pwlib_v1_10_0. In it, I do:
./configure --prefix=/usr
make opt
make install

• openh323_v1_18-0. :
./configure --prefix=/usr
make opt
make install

If you are running 1.4 might as well download the latest version of everything, zap, libpri and asterisk. When you make menuselect in asterisk remember to go to number 3 channel drivers and make sure h323 is selected and when I configured Asterisk I did it like openh323 and pwlib ./configure --/prefix=/usr it worked for me. When you run make is going to stop in the midle and ask you to run make again to load h323, do it and then run make install. You should be ready to go. If you don’t run the make samples, asterisk will not create the h323.conf so just find one and copy it in etc/asterisk. After that to check whether the module is loaded in the CLI>show channeltypes
it should be there. Then go to h323.conf file and change the bindaddress to your box IP, uncomment port 1720 and your statement in extensions.conf
exten => _Z.,1,Dial(H323/IP or Domanin you conect to ${EXTEN},50) That are to do it dude.

I also know you know most of these things I just included what I did, hope it works for you and tonight if you can’t go to bed you’ll have something to work with. :open_mouth: It will fly from the first try. If you think I can help you with anything else let me know.

Thank’s a lot - you wrote a real novell above, thank you, I’ll try this.
Anyway, do you have any problems while calling from H323 to SIP. I do. The problem is the absence of sound at the H323 side, when I use OOH323.

None at all, remember with h323 you have your disallow statement and your allowed codec right after it. Also keep in mind I use strictly VOIP no cards involved. So I turned off the fx’s in zaptel and kept the z’s while in the menuselect this way I have zaptel, zttranscode and ztdummy only.

I did have problems with sound using ooh323 and oh323 and was not able to figure it out. So I went with 1.4.4 asterirk h323 and is perfect.

Hope you get it going.

Damm, still doesn’t work.
I did all with flex, pwlib and openh323, and then tried to configure asterisk with --with-h323=PATH_TO_DIRECTORY_WHERE_OPENH323_IS_LOCATED (where I had ran make opt), but got a message:
'The OPENH323 installation on this system apeears to be broken.'
Also I tried oh323 for asterisk, but in this case I got a pack of mistakes from compiler (no such type, not defined etc).
I hate this all. Was it too hard for the developers to gather all I need to get the h323 into ONE archive?..

Anyway, I stiil hope to do something with the libchanh323.a that I got after running make in the asterisk/channels/h323 directory. I used openh323_Mimas_patch2 and the appropriate pwlib.

If you really want it to work, get a fresh start unless this is a production system which I doubt. I also use CentOS why, well I was told early on that asterisk was built on CentOS not that it makes a difference but I felt better using it and I downloaded the 4.4 server CD version which downloads in about 10 to 15 min. You don’t have to download the six cd’s just one. Also keep in mind that it takes a lot of homework, Asteriks needs additional software or dependencies depending on how you are using it. Check this following link to see additional programs needed for asterisk as well as freepbx, regardless, this link is for asterisk freepbx install but I use the yum update recommended here because it covers all asterisk versions with the exception of gcc-c++ which you also need. after your yum updates its a matter of flex which by the way has to be installed, pwlib and open h323 the versions described here without patches and asterisk. I have installed it 3 times this week just for testing and it works.
here’s the link

It’s not up to date but just change the versions and remember for this task download Asterisk’s stable version not svn.