Installation from current ISO to VM

The latest ISO 10/13 was downloaded yesterday. I wanted to try Asterisk on a VM (player 12 on Win10).

I encountered so many hangs and errors, I cannot begin to explain. Open Source is always my preferred platform, having used linux for 18 to 20 years.

The install hung (like many people reported) but if you are very patient, it eventually works. I changed to “NO RAID” for my VM and it took about half an hour to proceed.

The error in the GUI to login as an administrator is the most frustrating… no updates would run even under
SSH! I had 13.x.y.1 and it claimed it needed 13.x.y.2 for real??? I have never used Open Source software
that refused to work before. This is EMBARRASSING.

If you get 2% of people with problems reported… 98% with problems are walking away and shaking their heads.

Quite frankly, I am disgusted…
CentOS install hangs after virtual printer install
Next level hangs SHMZ 6.6 and NEVER proceeds
The whole mess of Asteriks Open Source is a TOTAL AVOID
worse than SPAM ware

Four hangs in a simple install…

You’ve created this thread for your problem. As I stated before, please do not comment on other threads with unhelpful comments and please do not hijack them for your own problem. If anyone has anything to add on this thread they will do so. I’ll be deleting any comments on other threads which are not relevant.

Please stop replying to threads that aren’t your own with your problem and screenshots. It may be because you are using the email mechanism and may not know this is occurring.

Sorry… I was replying to your email… is there a “working version” of asterisk, or is this early pre release beta… nothing I have tried for two days actually works… I don’t know the difference between FreePBX and Asterisk

Asterisk is a normal Linux application, not a distribution that you install from an ISO. It’s available from, but you have to install your own Linux (CentOS, Ubuntu, etc).

AsteriskNOW is a Linux distribution which includes Linux, Asterisk, and FreePBX (a separate project that provides a web GUI for configuration).

Many individuals use Asterisk itself on the Linux distribution they prefer and are familiar with.

I only tried to reply to you on one thread… still sorry :neutral_face:??

AsteriskNow, which I found on Asterisk Download, is not Asterisk?

I am confused (and sorry)… because “it”… the download I got from here… is of no value or use “yet”.

After fiver install attempt and about 20 reboots… nothing worked

AsteriskNOW CONTAINS Asterisk. Asterisk itself is a separate project and thing.

The problem is likely hardware/environment related. The ISO may not be up to date enough to support what you are trying to install it on. You can see if other people have experienced such a thing on the FreePBX forum[1], as AsteriskNOW is a version of the FreePBX distribution. They may even have a newer version of their distro that would work.


1 Like

I found the issue… VMware hijacks the install process (hence several reboots and corrupted install).

…much appreciation for your help and understanding