Install, configure Asterisk on CentOS 6.8 and Asterisk-GUI

Hello Asterisk Support,
I have followed this instructions to install this Asterisk VoIP application onto 64 bit CentOS 6.8 OS recently.
It was missing this package after i’ve compiled Asterisk and then compiled and installed jansson before going back and recompile asterisk.


  1. none of the service command worked yet the ‘/etc/init.d/asterisk start’ worked accordingly.
  2. i was not able to see a script of dahdi at all in the /etc/init.d directory , is this normal ?

I’ve took all the default configurations and edited /etc/asterisk/manager.conf, /etc/asterisk/http.conf accordingly.

Our manager wanted to install this additional web application which can be downloaded here;
svn checkout asterisk-gui

i used this instruction to try to get this web application to work but was unsuccessful.

using that exact configuration from, the web interface was able to pop up but when i entered the credentials and clicked on “login” on this web interface, the web interface wasn’t able to bring me to the next page and continue to bounce back and forth between the credential page and the page it wants to get to.

Are there anything i may have done wrong ? permission needed for a particular directorie(s) ? additional libraries missing to get this web interface to work ?

Second option:
is there a Asterisk iso file where the entire application including the OS will be able to be install on a clean server ?

Any additional assistance on this matter is much appreciated !

warm Regards,

The documentation and tutorials you are following are out of date, Disregard them.

You can download an ISO of Asterisk Now from here:

Instructions for compiling asterisk from source are here:

Hello John, “Asterisk expert”,

i see. so does the AsteriskNow iso included that particular web interface once the iso image has been installed ? Is this an image of CentOS underneath ?

Also, would it be best to install from iso instead of compiling this software on my own ? Compiling takes a long time and there are a few additional libraries requirements which i was not aware of initially.

what are your thoughts ? perhaps, what is the best route for me to pursue installing asterisk without too much or any compiling just a few twicks of configs and IP address of the default OS and Voila Asterisk is up and running.

warm Regards,

Asterisk Now is a complete Linux distribution with Asterisk, the DAHDI driver framework, and, the FreePBX administrative GUI, It has a web interface but not the one you were trying to install as the one you were trying to use has been abandoned for many years.

If you are just starting with Asterisk it is a easy way to get a base system installed and will not require any compiling.

Hello John,

Thanks man ! i will install this AsteriskNow iso image onto a server and go from there. i am glad made this iso file possible for a noobie like myself. I tried the compilation and it was a major headache.

i will download the iso files and go from there.

many thanks.


Note : AsteriskNow uses FreePBX GUI for the Asterisk administration and basic configuration, and FreePX is not supported on this forum so in case you get in trouble with your system configuration, you will need to address it to

Hello Ambiorixg,

I see, Asterisk and the Web based GUI are not one with one company.
If i ever run into issue with the web php interface, i will ask that Freepbx forum.
I was able to install AsteriskNOW 10.13 onto a laptop. Web interface came up and everything seems operational.
There shouldnt be anything wrong to install 10.13 instead of the 5211, assuming they are the same ?
I can see SHMZ is running a form of CentOS but not sure if its version 6.x or version 7.x.

Asterisk community has an excellent support.

thansk Again,