Asterisk GUI doesn't want to install

Hello All

I have installed Asterisk 1.4 on an ubuntu server (ver 8.04). However I can get the CLI to run, but when I do an svn checkout asterisk-gui the prompt disappears for a while and then returns with: Checked out revision 5002.

What am I doing wrong and how can I get the Asterisk gui to install?



For Configuring and maintanence of Asterisk servers I would suggest you to go for Asterisk Cli mode.

But if you need the asterisk gui, then check the site

Asterisk gui package will be available there, you can download the package to ubuntu server using command wget

Then go for commands
make clean
make install.

That URL checks out a single, README.txt file, that contains:

Please checkout the latest Asterisk-GUI from

I would agree that it is better to learn the CLI, even if you eventually use the GUI.

Hey Guys

Thank you so much for everyone’s help. I got it going although I had to apply a little workaround first. I tried the svn checkout “david55’s asterisk-gui URL” but again got the same message. “Check out versio 5002” (if I remember correctly). So I went ahead and deleted the existing gui directory as it had only 1 file and the .svn dir. I also deleted the 2.0 directory. I then tried the svn command again with the david55’s asterisk-gui URL and lo & behold. I saw streams of directories running over my screen being installed :smile: I then did ran the configure script. did a make, make clean and once all that was done I did a make checkconfig.

All seems good…this far. Now I can get the gui in my browser but I cannot log in. When I start asterisk CLI mode I go to my browser and log in with my password set in manager.conf but the CLI says tried to authenticate with non-existent user??? This tells me I need to first create the user? Is this correct? If so why secify the password in manager.conf? If I do not need to create the user in asterisk, what am I doing wrong with my gui login?

And just to reply to both about the cli. I am planning to study the asterisk cli commands. The only reason why I asked about the gui is cause my manager is not interested in learning the cli. So to make him happy I need something simpler to use :smile: However I am a cli freak. Even in linux I try to keep away from gui’s as much as possible.

Try to add a entry for the username and password for the webpage login in manager.conf.

By default in http.conf file the settings for the coded lines would be blocked and it wouldnt executed. Remove the ‘;’

In Http.conf :
bindaddr= (change to to get the access from any IP in the network./ Assign the IP address)
;redirect = / xxxxxxx/static/config/cfgbasic.html

In Manager.conf :
enabled = no (“change to yes to enable”)
;webenabled = yes
port = 5038
secret = password

Reload the asterisk server and try it.

Hi Althaf_css

I think I already tried what you suggested, but I will go through the steps again just to make double sure.

However, before I can do that what you suggested, I see another problem that is now occuring. When I start Asterisk from the CLI I get
[Mar 16 10:42:26] WARNING[18787]: http.c:417 ast_http_send: fwrite() failed: Illegal seek

I understand this is a Linux related problem, however I only see this when I start Asterisk. So it could be that something was not installed during the Asterisk installation process or more likely not installed properly/correctly.

This error occurs intermittently. Sometimes when I start Asterisk it shows up, sometimes it doesn’t show.

Can someone please advise where to look to fix this problem? I do not see any entries in my syslog for the above error although these errors are (obviously) in my Asterisk messages file.


Hi althaf_css

Thanks for your assistance. I have changed the [administrator] name to [username] as you said in your posting and now I can log in! :smile: I guess now the fun part begins. Getting to know Asterisk :smile:

Thanks again to everyone for their help.