How to force software detection for DTMF

Hi all


Why am I having DTMF detection problems?

Zaptel DTMF Detection Problems
DTMF detection problems can be caused by a number of different factors. The most common is running the X Windows System. Another cause of DTMF detection problems is the relaxdtmf option in Zapata.conf. It may need to be turned on or off. If you need to force all DTMF detection to be done in software, you can set vpmdtmfsupport to 0 in wctdm24xxp.c or wct4xxp.c and recompile, or you can specify it as a kernel module option at runtime.

Anyone knows how to “specify it as a kernel module options at runtime” because I just want to test it first without recompile the whole thing.


you could use “modprobe vpmdtmfsupport=0”, or add a line in /etc/modprobe.conf (or whatever your OS uses) to add an options line.

ohps… Thanks.

I am not the expert… would you mind tell me what modulename is?

do you mean… this?
modprobe zaptel vpmdtmfsupport=0

that would be those then.


Thanks a lot. That fix the problem :stuck_out_tongue: