DTMF problem


#1

I all,

I’ve a problem with dtmf. When the call is starting, if I answer and digit 1 for to interact with my IVR, asterisk don’t detected the DTMF.

this is my zapata.conf

[channels]
relaxdtmf=off
switchtype=euroisdn
pridialplan=local
prilocaldialplan=local
internationalprefix=00
nationalprefix=0
usecallingpres=yes
;busydetect=no
callprogress=yes
progzone=it
callwaitingcallerid=yes
echotraining=yes
echocancel=yes
echocancelwhenbridged=yes
overlapdial=yes
immediate=no
callerid=asreceived
language=it
rxgain=0.0
txgain=0.0
;--------------------------------
priindication = outofband
usecallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
busydetect=yes
busycount=3
answeronpolarityswitch=yes
hanguponpolarityswitch=yes
faxdetect=both
faxdetect=outgoing
;faxdetect=incoming
faxdetect=yes

;-------------------------------
group=1
signalling=pri_cpe
;context=pri1
context=default
channel => 1-15,17-31

This is mi zaptel.conf

loadzone =it
defaultzone =it
#span=1,0,0,ccs,ami,crc4
span=1,0,0,ccs,hdb3,crc4,yellow
#span=1,0,0,ccs,hdb3,crc4
bchan=1-15,17-31
dchan=16

I’m italian, any suggestion ?


#2

try setting this to =on

relaxdtmf=off