DTMF Double and triple tones - Everyone's problem


#1

Okay, revisiting a problem everyone seems to be having but only some successfully fix.

I am running the latest Asterisk kernel (1.2.7.1) and Zaptel drivers (1.2.5). I’m using a Digium TE406P card connected to a full PRI from a local provider. I first noticed the issue with our IVR application. We were getting double entries on single digit questions (1 for yes 2 for no was getting 11 or 22). I have called in from both a cell phone and land line to an extension in house, and everytime I press a key I hear a brief tone then a click at the end. If I hold the key down, I get a brief tone, then hear the click after a release the key. Here’s a list of fixes I’ve tried so far, they have had absolutley no affect on the system:

relaxdtmf=yes in zapata.conf
relaxdtmf=no in zapata.conf
Turned off echocancellation in zapata.conf
dtmfmode=inband set on extension I was testing on
dtmfmode=rfc2833 set on extension I was testing on
dtmfmode=info set on extension I was testing on

This topic showed promise forums.digium.com/viewtopic.php? … t=zap+dtmf

So I tried:
static int vpmdtmfsupport = 0;
to no effect.

I then tried the fixes listed here:

bugs.digium.com/view.php?id=5970
bugs.digium.com/view.php?id=6027

To no effect.

The above fixes seem to have worked for some, but for me the tone has sounded the same throughout, even though I have tried each fix and rebooted the server each time. I’ve now returned my system to a default state and am looking for other options.
If anyone has any thoughts, I’m all ears. If anyone has some troubleshooting information they would like me to gather, please let me know how. Setting asterisk cli to verbose generates no output when the keys are pressed.


#2

Just an update, removed the echo cancel card off the TE406 this weekend. It had no effect on performance. Looks like serving our IVR application through Asterisk may not be possible. I wish I had known this before I started.