[HELP] MOH errors in *.1.2.4

hello! been encountering this error since 1.2.3…configured my musiconhold to use native and not default. i put my mp3 files in /var/lib/asterisk/moh-native/ and here’s what comes out when i dial from the pstn into my * server. btw, im using and ivr to transfer calls to sip clients.

WARNING[25739]: file.c:509 ast_openstream_full: File /var/lib/asterisk/moh-native/music1 does not exist in any format
WARNING[25739]: res_musiconhold.c:225 ast_moh_files_next: Unable to open file ‘/var/lib/asterisk/moh-native/music1’: No such file or directory

i’ve checked and there’s the my moh file. was there some sort of configuration here that i still have to do? anyone who can help me with this? thanks in advance. :smile:


You might want to see the following thread; forums.digium.com/viewtopic.php? … usiconhold

thanks for the link! solved my problem already before i’ve read the thread, i just changed my mpg123’s version, i mean i updated my asterisk addons and things just worked fine again. anyway thanks again. :smile:

you could also ditch the buggy mpg123 and use asterisk’s native MOH player.

there are numerous threads on how to configure, but if you edit musiconhold.conf to reflect the following, it should work great: