Help make Asterisk look like PSTN using CAS T1

I have what I’ll politely call a “vintage” Nortel Option 81c that to it’s credit is really pretty bulletproof. The problem I have with it is that it doesn’t accept PRI, all of our routes from the PSTN are coming over CAS T1s that are programmed up in the Nortel as Wink start E&M DID trunks. What I am looking to do is replicate that on another route on the Nortel and have Asterisk appear to be the same as our PSTN provider as far as Nortel is concerned. This is what I have gotten from our provider regarding how the current T1s we have are configured on their (The PSTN) side.

Start Mode: Wink Start
Tone Type: DTMF
Inpulse: CALLED PARTY ADDR (national) *
Outpulse: rcv Wink spill digits (4)

and here are my current chan_dahdi.conf and system.conf



channel => 1-24


Can anyone enlighten me on how I need to set that up in Asterisk? I have tried every combination of E&M I can find and even swapped from ESF/B8ZS to D4/AMI on both machines and I still get nothing of use. I can get the T1’s to go green on both machines and I can see activity and both sides will seize a channel to use but here’s the output I get from Asterisk when I try to make a call over to it:

– Starting simple switch on ‘DAHDI/24-1’
– Unknown extension ‘s’ in context ‘nortel’ requested
– <DAHDI/24-1> Playing ‘ss-noservice.ulaw’ (language ‘en’)
– Hanging up on ‘DAHDI/24-1’
– Hungup ‘DAHDI/24-1’

As you can see for some reason I’m not seeing any digits passed to it and I know that the nortel has to be passing something otherwise the PSTN wouldn’t know how to route it!

Any help would be greatly appreciated

I had done something similar. I had a Nortel Option 61C with two connections to the Telco. One was a PRI and the other was a CAS T1.

In my chan_dahdi.conf this is how I had it defined…

; Span 5: TE4/1/3 "T4XXP (PCI) Card 1 Span 3"
signalling = em_w
channel => 97-120

Excellent, I’ll give that a try. Hey we seem to be in the same town… I work at the older of the two hospitals in town, PM me if you have a chance to sit down and talk about various installations. I’d be happy to buy you a beer or a cup of coffee, whatever your pleasure.

Well I gave it a shot with those extra parameters and I can complete a call if I add something to the “s” extension but i’m still not able to do any pattern matching or extension matching since I don’t seem to be getting digits…

Starting simple switch on ‘DAHDI/24-1’
– Unknown extension ‘s’ in context ‘nortel’ requested
– <DAHDI/24-1> Playing ‘ss-noservice.ulaw’ (language ‘en’)
– Hanging up on ‘DAHDI/24-1’
– Hungup ‘DAHDI/24-1’

I guess I’m looking for the AMI/DNIS information so I can start stripping stuff away and use it for routing but I don’t seem to be getting it from the T1…