* to Nortel 11 using T1 link

Hi,

I have a Nortel Option 11c connected to the telco with a T1. Config on the Nortel is for dms100.

I have placed a RedFone 2xT1 device in-between the Nortel & the outside world.

I am using ‘RedFone compatable’ Asterisk 1.4

There are no errors on the T1 connections & no errors in zttool or within Asterisk. ‘pri show spans’ shows no errors.

Calls to & from the PSTN to Asterisk - no problems.

Calls into the Nortel from the PSTN are in a 4 digit format.

Calls to or from the Nortel result in ‘hangup cause 54’ errors.

I tried using qsig instead of dms100 - no problems until calls are made - then the same errors…

I seem to be experiencing the same error as this guy below - but the final ‘fix’ was not revealed…

tek-tips.com/viewthread.cfm?qid=1455378

I don’t believe this is a RedFone issue - as all the T1 lines appear to be functioning correctly. I believe this is a signalling issue with how Asterisk is communicating with the Nortel - possibly a problem within libpri. Internet reading has shown the Nortel can be very picky.

I have experimented a lot trying to resolve this problem - but it’s seems to be beyold my level of telecoms understanding.

If someone has fixed this issue using paid support - I would be interested in who you used for this & how much it cost. I don’t mind paying to resolve this.

Please find my Asterisk config files below.

Thanks for any help in advance.

Paul Adams

Zaptel.conf
##Automatically Generated zaptel configuration file
##Generator Version 0.2.5

dynamic=ethmf,eth2/00:50:c2:65:d3:da/0,24,0
dynamic=ethmf,eth2/00:50:c2:65:d3:da/1,24,1

bchan=1-23
dchan=24

bchan=25-47
dchan=48

loadzone=us
defaultzone=us

zapata.conf
[trunkgroups]
[channels]
language=en
usecallerid=yes
hidecallerid=no
callwaiting=no
callwaitingcallerid=yes
restrictcid=no
usecallingpres=no
threewaycalling=yes
callreturn=yes
transfer=yes
cancallforward=yes
echocancelwhenbridged=yes
echocancel=yes
musiconhold=default
rxgain=0.0
txgain=0.0
switchtype=dms100
immediate=no
overlapdial=yes
pridialplan=unknown
prilocaldialplan=unknown
;priindication=outofband
;resetinterval=86400
;
;
;
group=1
context=from-pstn
signalling=pri_cpe
callerid=asreceived
callgroup=1
pickupgroup=1
channel=>1-23
;
;
;
group=2
context=from-nortel
signalling=pri_net
callgroup=2
pickupgroup=2
callerid=asreceived
channel=>25-47
;
;
;
; For fax detection, uncomment one of the following lines. The default is OFF
;faxdetect=both

extensions.conf(trimmed down for posting on the forum)
[from-nortel]
exten => _XX.,1,Dial(Zap/g1/${EXTEN})
;
;
;
[from-pstn]
exten => 58XX,1,Dial(Zap/g2/${EXTEN})

Are you using the Asterisk as tandem switch?

pstn----t1–asterisk----t1-----nortel----58xx

Is 58xx a DID call from the PSTN?

Please check first your extensions.conf

Maybe you need to put _58XX instead of just 58XX.

Yes - initally - Asterisk as a tandem switch - then move my users one by one to Asterisk & eventually turn off the Nortel.

DOH! :laughing:

Thanks for spotting that…

Paul

Hi Paul,

Did you fixed the problem?
if yes, could you give me some hints

Nortel <–T1–> Asterisk <-- T1–> PSTN

Asterisk to PSTN -> OK
PSTN to Asterisk -> OK
Nortel to PSTN -> OK
PSTN to Nortel -> Failed with the error below

< Protocol Discriminator: Q.931 (8) len=12
< Call Ref: len= 2 (reference 7/0x7) (Terminator)
< Message type: STATUS (125)
< [08 02 85 e4]
< Cause (len= 4) [ Ext: 1 Coding: CCITT (ITU) standard (0) Spare: 0 Location: Private network serving the remote user (5)
< Ext: 1 Cause: Invalid information element contents (100), class = Protocol Error (e.g. unknown message) (6) ]
< [14 01 06]
< Call State (len= 3) [ Ext: 0 Coding: CCITT (ITU) standard (0) Call state: Call Present (6)
– Processing IE 8 (cs0, Cause)
– Processing IE 20 (cs0, Call State)

< Protocol Discriminator: Q.931 (8) len=9
< Call Ref: len= 2 (reference 7/0x7) (Terminator)
< Message type: RELEASE COMPLETE (90)
< [08 02 81 81]
< Cause (len= 4) [ Ext: 1 Coding: CCITT (ITU) standard (0) Spare: 0 Location: Private network serving the local user (1)
< Ext: 1 Cause: Unallocated (unassigned) number (1), class = Normal Event (0) ]
– Processing IE 8 (cs0, Cause)

zaptel.conf

Span 1: TE2/0/1 “T2XXP (PCI) Card 0 Span 1” (MASTER)

span=1,1,0,esf,b8zs
bchan=1-23
dchan=24

Span 2: TE2/0/2 “T2XXP (PCI) Card 0 Span 2”

span=2,0,0,esf,b8zs
bchan=25-47
dchan=48

Global data

loadzone = uk
defaultzone = uk

Zapata.conf

group=1,11
context=card1port1
switchtype=4ess
signalling=pri_cpe
callerid=asreceived
channel => 1-23

group=2,12
context=from-nortel
switchtype=4ess
signalling=pri_net
callerid=asreceived
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
rxganin=0.0
txganin=0.0
nsf=none
relaxdtmf=yes
facilityenable=yes
pridialplan=national
channel => 25-47

extensions.conf

[card1port1]

exten => 9546,1,Answer()
exten => 9546,n,SetCallerID,${CALLERID(num)}
exten => 9546,n,Dial(Zap/g2/9546,20,)
exten => 9546,n,Hangup()

[from-nortel]
exten => _X.,1,Answer()
exten => _X.,n,SetCallerID,${CALLERID(num)}
exten => _X.,n,Dial(Zap/g1/${EXTEN},20,)
exten => _X.,n,Hangup()

Nortel DCH configuration

ld 22
PT2000

REQ prt
TYPE adan
.
.
.
ADAN DCH 11
CTYP TMDI
CARD 01
PORT 1
DES did
USR PRI
DCHL 1 0
OTBF 32
PARM RS232 DTE
DRAT 64KC
CLOK EXT
IFC APAC
CNTY HKNG
ISDN_MCNT 300
CLID OPT4
PROG NCHG
CO_TYPE STD
SIDE USR
CNEG 1
RLS ID **
RCAP BRI
MBGA NO
OVLR NO
OVLS NO
T310 10
INC_T306 2
OUT_T306 2
T200 3
T203 10
N200 3
N201 260
K 7
.
.
.

I have tried different switchtype(national,ni1,dms100,4ess,5ess,euroisdn) in zapata.conf, but still not work

Thank for any help

Cyrus

Hi - I did get my problem fixed - but I believe it’s a different issue to yours.

My problem was Asterisk ‘DMS100’ signaling not being 100% compatable with Nortel ‘DMS100’ signaling. Both worked fine using DMS100 direct to the telco - but errored connected to each other when placing a call.

Reprogramming the Nortel to NI2 from DMS100 (and of course changing Asterisk to NI2) resulted in it all working perfectly first time.

I found an excellent freelance Nortel tech who did the reprogramming work in one hour - he’s $75 an hour if you want me to put you in touch - that’s about 40 quid an hour in your money…

Paul

Hi Paul,

Thanks for your reply,
I will try to call the local support.

Thanks
Cyrus

Hi ,

Finally I fixed the problem without changing configuration in Nortel Option 11c,

hope this can help others with the similar problem

  1. enable the pri debug on span 1(connected to telco ),
  • make a call from outside to internal ext.
  • capture all debug messages
  1. enbale the pri debug on span 2 (connected to nortel)
  • make a call from outside to internal ext.
  • capture all debug messages
  1. Compare the output from step 1&2
    I found that 2 things are missing in output of step2

    < Sending Complete (len= 1)

AND

< Progress Indicator (len= 4) [ Ext: 1 Coding: CCITT (ITU) standard (0) 0: 0 Location: Network beyond the interworking point (10)
< Ext: 1 Progress Description: Call is not end-to-end ISDN; further call progress information may be available inband. (1) ]

  1. Add “w” to Dial cmd to enable “sending complete” message
    Reference : bugs.digium.com/view.php?id=1857
  • extensions.conf
    exten => 9546,1,Answer()
    exten => 9546,n,SetCallerID,${CALLERID(num)}
    exten => 9546,n,Dial(Zap/g2/9546w,20,)
    exten => 9546,n,Hangup()
  1. change “switchtype” to “national” and add “overlapdial” on span2 in zapata.conf

    switchtype=national
    overlapdial=yes

restart zaptel and asterisk, turn on the debug and make a call
then “sending complete” and “progress indicator” comes back and everything works now.

I have tried all others switchtype(ni1, dms100, 4ess, 5ess, euroisdn and qsig),
only “national” can produce the “progress indicator”

configuration file

  • zaptel.conf

Span 1: TE2/0/1 “T2XXP (PCI) Card 0 Span 1” (MASTER)

span=1,1,0,esf,b8zs
bchan=1-23
dchan=24

Span 2: TE2/0/2 “T2XXP (PCI) Card 0 Span 2”

span=2,0,0,esf,b8zs
bchan=25-47
dchan=48

Global data

loadzone = uk
defaultzone = uk

  • zapata.conf
    ; Span 1: TE2/0/1 “T2XXP (PCI) Card 0 Span 1” (MASTER)
    group=1,11
    context=card1port1
    switchtype=4ess
    signalling=pri_cpe
    callerid=asreceived
    channel => 1-23

;; Span 2: TE2/0/2 "T2XXP (PCI) Card 0 Span 2"
group=2,12
context=from-nortel
switchtype=national
overlapdial=yes
pridialplan=unknown
prilocaldialplan=unknown
signalling=pri_net
callerid=asreceived
channel => 25-47

-extension.conf

[card1port1]
exten => 9546,1,Answer()
exten => 9546,n,SetCallerID,${CALLERID(num)}
exten => 9546,n,Dial(Zap/g2/9546w,20,)
exten => 9546,n,Hangup()
.
.
.

[from-nortel]
exten => _X.,1,Answer()
exten => _X.,n,SetCallerID,${CALLERID(num)}
exten => _X.,n,Dial(Zap/g1/${EXTEN},20,)
exten => _X.,n,Hangup()

Cyrus