GUI 2.0 does not show menu options

Hey there I could really use some help.

I installed the new GUI 2.0 and everything seems to be fine except that the only menu option (on the left side of screen) that shows up is the system status button. It works when I press it, but there are no other options listed. This was an upgrade from the first version of the GUI. when I ran the make checkconfig it says everything is fine. I checked the source code for the frame that the menu options are in and it looks ok too. I also checked the source directory for the files and they are all there including the java scripts. Version 1.0 worked fine.

Any thoughts would be greatly appreciated.




I have given my asterisk box a FQDN and I still get the same thing. Essentiall I can log in fine and it authenticates me ok. I just dont see any menu options other than “systems status” to the left side of my screen. I have disabled all popups and filters of any kind on firefox 3. I have enabled Java and javascript and verified that those are working.

I do keep getting a popup each time I login telling me, “Your configuration will now be upgraded to work with the latest version of GUI.
An automatic backup of your old configration is available from the backups panel.” and that happens everytime I try to login. I only have OK as an option and it will continue beyond that.

It appears to be running scripts, but it seems to only run 1 or 2 (no way to actually tell). It gets past the scripts popup pretty quick.

This one is baffeling.

Thanks for any additional help!


Hi Rob.

Please try to delete all cookies and cache.

Did you tried to set permissions 777 on /etc/asterisk/*?

When I upgraded from the 1.0 version to 2.0, I remember alot of stuff happening and it took a few minutes to update my configs. You may also want to upgrade the gui again and see if it fixes it. You may also want to try another version of firefox too

Ok guys…first off thanks to those who responded and attempted to help. I still have the same problem, but I have been reading like a madman and have come up with a little more information to help shed some additional light on this issue.

  1. When I login it takes my user and password. For the record I have created two users and they both login to the gui fine.

  2. Everytime I login to the gui my browser pops up a window and says, “parsing config files” it keeps going through this for about 45 seconds to 2 minutes. When the parsing is completed it shows me the login page and below the username and password fields it says “connected”. However on the left side of the screen I only see the “system status” button.

  3. When I click the system status button it works and shows me the current system status with all of the extensions defined, etc. Each extension has a link by the extension # and I can click that link. When I do I, it goes to the extensions page for the system. Also when I click on the extension I notice that the extensions panel button appears on the left menu plane.

  4. now I have 2 buttons on the menu plane and they both work and I can click back and forth between them.

  5. When I am in the extensions area it says that I have no dialplan defined on each extension. I click on that and low and behold I am taken to the dial plan area. Also the dial plan button displays in the menu plane on the left side of the screen. Now I have 3 buttons and they all work fine.

  6. I can click on dial rules from the dialplan screen and the same thing happens for the dial rules button as well. Since there are no other places to link from within those 4 screens thats all I can get.

  7. When I logout and back in the menu options are all gone except for the system status button.

  8. I have tried all forms of resets to cache and cookies. I have downgraded firefox from 3 to 2. I have tried opera, safari, netscape, and IE. They all behave simalarly.

  9. I have changed file permissions (CHMODE 777) on all files from /etc/asterisk and all the subdirectories under them.

  10. I have re-installed the gui about 20 times. Each time the make check config comes up with no errors

  11. I have been able to get to the configuration setup screen by using the following url: my_ip_address:8088/static/config … stall.html I have been able to go through all 7 steps. then it goes into the parsing config files again and is back to where I started.

  12. I switched from an ip address to a FQDM for the server and that had no effect at all.

I am stumped as to where to go from here. Is there a way to delete all of the configuration files in static-http/config directory and them have them created from scratch whith a new install of the gui?

Where is the gui backing up the files to when it says backing up your files?

Any more advice would be greatly appreciated.

Thanks in advance,


I notice that when its “parsing config files” the browser appears to be looping and reloading the page over and over again. I would guess it needed to reload the page between each parsing, but it may be in a loop of some kind…