Fix for res_features.so: undefined symbol: ast_monitor_stop


#1

I’m posting this to help other people who might have encountered the same problem, because I searched and searched this forum (and Google) and couldn’t find the answer.

I’ve been running Asterisk on a Gentoo box for a couple years (not a newbie, to Asterisk or Gentoo). This week tried to install asterisk 1.2.9.1 on a Gentoo 2.6 kernel box by downloading and compiling the sources (so it was an install starting from nothing, no previous sources or conf files). Everything compiled fine, but got the error when launching asterisk:

Betweeen this board and Google, got all kinds of crazy answers for not loading things, patching things, etc. Nothing worked. I was sure I compiled correctly (even did the make linux26 on zaptel, etc.) and sure I loaded the zaptel and wctdm modules in the right order, and sure the conf files were all correct and valid. Everything that needed to be in my kernel was there, all packages asterisk depended on where installed on my system. The only difference was moving to an updated Gentoo box on a 2.6 kernel, plus the latest release of asterisk.

So after much painful message board and google searches, I finally found this in the Gentoo bug list:

http://bugs.gentoo.org/show_bug.cgi?id=126755

And the comment at the end:

This fix worked great for me. Hope that helps someone. Not only Gentoo users but probably other distros starting with a new asterisk install. I’m putting the answer here for completness sake and to thank all the previous contributors for posting their answers on this forum, a great community. :smile: