Error compiling zaptel on suse linux kernel 2.6.16


#1

Hey Guys,

I am unable to compile zaptel on my Suse 10 with kernel 2.6.16, I have installed all the packages needed but it still gives me the make *** linux error 2 when I try to make the kernel. I have heard alot people having this issue but where ever I go they it states that it was only in 2.6.9 kernel and it should be fixed by a patch. Every thing is updated on my computer using Kpackage, I am using Suse Slick 10. I already tried compiling asterisk and installing it, that works fine only zaptel is the problem. I also compiled sounds, addons and stuff they worked fine but zaptel dosent. Anybody have any ideas??

Do I have to edit the make file or anything… need help here


#2

Post some of the output from when you compile zaptel it will be easier to see whats going on.

Scott


#3

I’ve been using Suse Linux 10 for a while and haven’t had any problems compiling Zaptel. Normally when this happens it is because the kernel-source package isn’t installed or needs to be updated.

Yast -> Software -> Install and Remove Software

Search for ‘kernel-source’. Install the package, it’s quite large.

Try recompiling.

After running YOU (Yast Online Update) kernel updates you need to restart your computer, and reload the kernel-source package.

Yast -> Software -> Install and Remove Software

Search for ‘kernel-source’. Update the package.

If this doesn’t do the trick, you will need to cut and paste the exact error messages.

Dan


#4

I just compil zaptel on a clean 2.6.16.11 kernel.

I had to comment a ligne in file (somthing usb) where it try to set a owner varible for the module.

And on another module there is a rtc_interrupt fonction that need to be rename at two places beacause there is now a rtc_interrupt function inside linux and definied in rtc.h

I install it and load manually some module, nothing crash !

i will try it with my new TDM card tonight. (I am a newbie in asterisk)

good luck


#5

i dont really require zaptel because i have no digium hardware and i m not planning to use it. so i think I can just install asterisk without zaptel and other stuff with it. i m in process of installing freepbx hope everything goes good


#6

If you down zaptel-1.2.5 from the asterisk home page, It is 2.6. aware and compile without problem.

Now I need a lots of aspirin to understand Asterisk itself.

C.