Dahdi keeps loading dahdi_dummy


If it helps - I am using:

  • CentOS 5.2
  • Asterisk
  • Dahdi linux 2.0.0 - patched with the RedFone TDMoE driver from Digium (20595)
  • Dahdi tools 2.0.0 - patched with the RedFone TDMoE driver from Digium (20121)
  • LibPri 1.4.8
  • RedFone 750-5050-EC Dual

I’ve edited the /etc/dahdi/modules file & remarked out everything - then added dahdi_dynamic & dahdi_dynamic_eth

I run the config utility for the redfone device (fonulator) & everything is good with the device.

My issue is that everytime I start dahdi - it always loads the dahdi_dummy - even when the fonulator utility has been run.

During bootup - it says the /proc/dahdi cannot find a hardware timing device & therefore, it starts dahdi_dummy - but the red-fone device is running and ready.

If I manually remove the dahdi_dummy module from the command line (rmmod dahdi_dummy) - everything is fine - Asterisk works fine.

How do I stop dahdi_dummy from loading?



Sound like a similiar problem to one I had. See http://forums.digium.com/viewtopic.php?t=65988


Have you had a look in /etc/init.d at the dahdi file there. also have a look at the modprobe files.

what does service dahdi restart do ?


Thanks for the suggestions…

pmlco - checked the blacklist - dynamic or dynamic_eth not listed.

ianplain - checked the files - seems OK. There’s a section in the /etc/init.d/dahdi file that checks for dynamic spans before starting the other modules. It seems to check for a dynamic_ethmf file in /proc/dahdi folder first. That file is there.

A service dahdi restart does start dahdi_dummy as well as dahdi_dynamic & dahdi_dynamic_eth



Ok as a work around remove the entry for loading dummy or change it to echo back something,

TBH if the spans don’t load then loading dummy isn’t going to be much help :smile:


Yer - fair point - I’ll disable it…

Ta - Merry Christmas…



Ive spent hours trying to force dahdi_dummy to work and provide timing